summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-10-15 16:04:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-10-15 16:04:48 +0200
commit559e06b61c66af8cfee8fdf9bc356466ad55486e (patch)
tree2b5a3acb53daf40cf8bc26b4998c8f2baae54697 /gnu/packages/music.scm
parent1133ca44608c0df15e1a9888ad026e13a6eca6f7 (diff)
downloadguix-patches-559e06b61c66af8cfee8fdf9bc356466ad55486e.tar
guix-patches-559e06b61c66af8cfee8fdf9bc356466ad55486e.tar.gz
gnu: patchmatrix: Update to 0.16.0.
* gnu/packages/music.scm (patchmatrix): Update to 0.16.0. [arguments]: Remove custom phase make-gzip-archive-writable.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm59
1 files changed, 24 insertions, 35 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 250f3136bb..22db0cf604 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4053,43 +4053,32 @@ notation and includes basic support for digital audio.")
(license license:gpl2)))
(define-public patchmatrix
- ;; There have been no releases for more than a year.
- (let ((commit "a0b0b1e791f4574d5abd059cfe1819c71e8b18d5")
- (revision "1"))
- (package
- (name "patchmatrix")
- (version (git-version "0.12.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/OpenMusicKontrollers/patchmatrix.git")
- (commit commit)))
- (file-name (string-append "patchmatrix-" version "-checkout"))
- (sha256
- (base32
- "0pph4ra7aci3rbpqvvr564pi16vxrk448bmvp8985cd9lbjlrp3m"))))
- (build-system meson-build-system)
- (arguments
- '(#:tests? #f ; no test target
- #:phases
- (modify-phases %standard-phases
- (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
- (lambda* (#:key outputs #:allow-other-keys)
- (map make-file-writable
- (find-files (assoc-ref outputs "out") ".*\\.gz$"))
- #t)))))
- (inputs
- `(("jack" ,jack-1)
- ("lv2" ,lv2)
- ("mesa" ,mesa)))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (home-page "https://github.com/OpenMusicKontrollers/patchmatrix")
- (synopsis "Simple JACK patch bay")
- (description "PatchMatrix is a patch bay for the JACK audio connection
+ (package
+ (name "patchmatrix")
+ (version "0.16.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenMusicKontrollers/patchmatrix.git")
+ (commit version)))
+ (file-name (git-file-name "patchmatrix" version))
+ (sha256
+ (base32
+ "020vp7zzxxzzjfic57vkpg68dm8hi98ilr1bj88xjsv6i47xmjbn"))))
+ (build-system meson-build-system)
+ (arguments '(#:tests? #f)) ; no test target
+ (inputs
+ `(("jack" ,jack-1)
+ ("lv2" ,lv2)
+ ("mesa" ,mesa)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/OpenMusicKontrollers/patchmatrix")
+ (synopsis "Simple JACK patch bay")
+ (description "PatchMatrix is a patch bay for the JACK audio connection
kit. It provides a patch bay in flow matrix style for audio, MIDI, CV, and
OSC connections.")
- (license license:artistic2.0))))
+ (license license:artistic2.0)))
(define-public sorcer
(package