summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2019-11-08 10:59:52 +0000
committerMarius Bakke <mbakke@fastmail.com>2019-11-14 00:16:11 +0100
commit5182fbe0632a565c257c94a10e1e4ea681466c8b (patch)
treef6f64525e58eec26274c5171894596cca42d9790 /gnu/packages/music.scm
parent95f6e6dad80aa198b5b8d02851050bcfe0928c26 (diff)
downloadguix-patches-5182fbe0632a565c257c94a10e1e4ea681466c8b.tar
guix-patches-5182fbe0632a565c257c94a10e1e4ea681466c8b.tar.gz
gnu: Add sherlock-lv2.
* gnu/packages/music.scm: (sherlock-lv2): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index cc41c04ddb..8c46287fce 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4737,3 +4737,32 @@ for integration into status line generators or other command-line tools.")
effects. It contains a bitcrusher, delay, distortion, equalizer, compressor,
and reverb.")
(license license:gpl2+)))
+
+(define-public sherlock-lv2
+ (package
+ (name "sherlock-lv2")
+ (version "0.20.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://git.open-music-kontrollers.ch/lv2/"
+ "sherlock.lv2/snapshot/sherlock.lv2-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1c5xajpss9h8lbyx160bbzg8va50n2d74qwnxig9sf468rzmha1y"))))
+ (build-system meson-build-system)
+ (inputs
+ `(("libx11" ,libx11)
+ ("mesa" ,mesa)
+ ("sratom" ,sratom)))
+ (native-inputs
+ `(("flex" ,flex)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Investigative LV2 plugin bundle")
+ (description "The Sherlock plugin bundle contains LV2 plugins for
+visualizing LV2 atom, MIDI and OSC events. They can be used for monitoring
+and debugging of event signal flows inside plugin graphs.")
+ (home-page "https://open-music-kontrollers.ch/lv2/sherlock/")
+ (license license:artistic2.0)))