summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2019-11-08 08:26:58 +0000
committerLudovic Courtès <ludo@gnu.org>2019-11-09 23:04:15 +0100
commit50c5215c9c640d742238c8896702e0d3228bff0c (patch)
treef4a6e29b5a553f4b3c38123fb50d3507d18a7211 /gnu/packages/music.scm
parentec574bb3fb5131fcb904248f307095d5ed29e6b7 (diff)
downloadguix-patches-50c5215c9c640d742238c8896702e0d3228bff0c.tar
guix-patches-50c5215c9c640d742238c8896702e0d3228bff0c.tar.gz
gnu: Add artyfx
* gnu/packages/music.scm: (artyfx): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a30765e87f..2f60242f39 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4699,3 +4700,40 @@ You can also get metadata about the playing track such as the artist and title
for integration into status line generators or other command-line tools.")
(home-page "https://github.com/altdesktop/playerctl")
(license license:lgpl3+)))
+
+(define-public artyfx
+ (package
+ (name "artyfx")
+ (version "1.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/openAVproductions/openAV-ArtyFX.git")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "012hcy1mxl7gs2lipfcqp5x0xv1azb9hjrwf0h59yyxnzx96h7c9"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; no tests included
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-architecture-specific-flags
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("-msse2 -mfpmath=sse") ""))
+ #t)))))
+ (inputs
+ `(("cairo" ,cairo)
+ ("libsndfile" ,libsndfile)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("lv2" ,lv2)))
+ (home-page "http://openavproductions.com/artyfx/")
+ (synopsis "Audio effect LV2 plugin bundle")
+ (description "ArtyFX is an LV2 plugin bundle of artistic real-time audio
+effects. It contains a bitcrusher, delay, distortion, equalizer, compressor,
+and reverb.")
+ (license license:gpl2+)))