summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-09-26 05:01:26 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-09-26 05:24:30 +0200
commit3f3d712cc525d65c184cea4c2048a62a4ec87c73 (patch)
tree8e7797b549a5415f1466dfa5ed918f1d636519ad /gnu/packages/music.scm
parentd94ec407585dc4d34ec80a28567f98205c4f24c2 (diff)
downloadguix-patches-3f3d712cc525d65c184cea4c2048a62a4ec87c73.tar
guix-patches-3f3d712cc525d65c184cea4c2048a62a4ec87c73.tar.gz
gnu: beets: Update to 1.4.9.
* gnu/packages/music.scm (beets): Update to 1.4.9. [source]: Remove patch. [arguments]: Remove more Python 3.7 compatibility fixes. * gnu/packages/patches/beets-python-3.7-fix.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index b28b375067..508f2ea3bf 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2813,14 +2813,13 @@ Songs can be searched by artist, name or even by a part of the song text.")
(define-public beets
(package
(name "beets")
- (version "1.4.7")
+ (version "1.4.9")
(source (origin
(method url-fetch)
(uri (pypi-uri "beets" version))
- (patches (search-patches "beets-python-3.7-fix.patch"))
(sha256
(base32
- "0w3gz69s9gf5ih69d4sddgh7ndj7658m621bp742zldvjakdncrs"))))
+ "0m40rjimvfgy1dv04p8f8d5dvi2855v4ix99a9xr900cmcn476yj"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -2829,12 +2828,6 @@ Songs can be searched by artist, name or even by a part of the song text.")
(lambda _
(setenv "HOME" (string-append (getcwd) "/tmp"))
#t))
- (add-after 'unpack 'make-python3.7-compatible
- (lambda _
- ;; See <https://github.com/beetbox/beets/issues/2978>.
- (substitute* "beets/autotag/hooks.py"
- (("re\\._pattern_type") "re.Pattern"))
- #t))
(replace 'check
(lambda _
(invoke "nosetests" "-v"))))))