summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2018-05-27 13:15:41 +0100
committerEfraim Flashner <efraim@flashner.co.il>2018-05-27 22:33:01 +0300
commit01c4869003884fc28b8993077474399b67d7be1c (patch)
treeed5aedfac10fe4803da0c2b42d2f7160d0d79b34 /gnu/packages/music.scm
parent3a69f5f2d348be38026c56ce3e9f04302e6d198e (diff)
downloadguix-patches-01c4869003884fc28b8993077474399b67d7be1c.tar
guix-patches-01c4869003884fc28b8993077474399b67d7be1c.tar.gz
gnu: libmygpo-qt: Fix Qt 5.11 build.
The update to Qt 5.11.0 broke libmygpo-qt. It turned it was using a deprecated CMake function (qt5_use_moduldes). Let's pick up two upstream patches that fix the issue: https://github.com/gpodder/libmygpo-qt/pull/15 As mentioned in the the pull request, there is now a test failure but it looks harmless. * gnu/packages/patches/libmygpo-qt-fix-qt-5.11.patch, gnu/packages/patches/libmygpo-qt-missing-qt5-modules.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/music.scm (libmygpo-qt)[source]: Add patches. [arguments]: Build tests but do not run them. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 7e98fa74cf..cc7926f85c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3846,12 +3846,19 @@ by The Echo Nest.")
"libmygpo-qt/libmygpo-qt." version ".tar.gz"))
(sha256
(base32
- "1kg18qrq2rsswgzhl65r3mlyx7kpqg4wwnbp4yiv6svvmadmlxl2"))))
+ "1kg18qrq2rsswgzhl65r3mlyx7kpqg4wwnbp4yiv6svvmadmlxl2"))
+ (patches (search-patches "libmygpo-qt-fix-qt-5.11.patch"
+ "libmygpo-qt-missing-qt5-modules.patch"))))
(build-system cmake-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
`(("qt" ,qtbase)))
+ (arguments
+ `(#:configure-flags '("-DMYGPO_BUILD_TESTS=ON")
+ ;; TODO: Enable tests when https://github.com/gpodder/gpodder/issues/446
+ ;; is fixed.
+ #:tests? #f))
(home-page "http://wiki.gpodder.org/wiki/Libmygpo-qt")
(synopsis "Qt/C++ library wrapping the gpodder web service")
(description "@code{libmygpo-qt} is a Qt/C++ library wrapping the