summaryrefslogtreecommitdiff
path: root/gnu/packages/multiprecision.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-01-19 23:59:20 -0500
committerMark H Weaver <mhw@netris.org>2018-01-19 23:59:20 -0500
commite074a655dd6497daafbd62737e3b63f3d5aa7985 (patch)
tree2b198ba5c664cdd58e155f3c0113d1cebde0fc91 /gnu/packages/multiprecision.scm
parent6d7b26a39faf42c37f15dc64a30a77e5e194ea23 (diff)
parentccb5cac17be98aaa9c3225605d6170c675d8e8e6 (diff)
downloadguix-patches-e074a655dd6497daafbd62737e3b63f3d5aa7985.tar
guix-patches-e074a655dd6497daafbd62737e3b63f3d5aa7985.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/multiprecision.scm')
-rw-r--r--gnu/packages/multiprecision.scm65
1 files changed, 36 insertions, 29 deletions
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index 69272eb18a..8bd4a848fe 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -59,13 +60,14 @@
(else '())))))
(synopsis "Multiple-precision arithmetic library")
(description
- "GMP is a library for arbitrary precision arithmetic, operating on
-signed integers, rational numbers and floating point numbers. The precision
-is only limited by the available memory. The library is highly optimized,
-with a design focus on execution speed. It is aimed at use in, for example,
-cryptography and computational algebra.")
+ "@dfn{GMP} (the GNU Multiple Precision Arithmetic Library) is a library for
+arbitrary-precision arithmetic, operating on signed integers, rational numbers
+and floating point numbers. The precision is only limited by the available
+memory. The library is highly optimized, with a design focus on execution
+speed. It is aimed at use in, for example, cryptography and computational
+algebra.")
(license lgpl3+)
- (home-page "http://gmplib.org/")))
+ (home-page "https://gmplib.org/")))
(define-public gmp-6.0
;; We keep this one around to bootstrap GCC, to work around a compilation
@@ -97,10 +99,11 @@ cryptography and computational algebra.")
(build-system gnu-build-system)
(outputs '("out" "debug"))
(propagated-inputs `(("gmp" ,gmp))) ; <mpfr.h> refers to <gmp.h>
- (synopsis "C library for arbitrary precision floating-point arithmetic")
+ (synopsis "C library for arbitrary-precision floating-point arithmetic")
(description
- "GNU MPFR is a C library for performing multiple-precision,
-floating-point computations with correct rounding.")
+ "GNU@tie{}@dfn{MPFR} (Multiple Precision Floating-Point Reliably) is a C
+library for performing multiple-precision, floating-point computations with
+correct rounding.")
(license lgpl3+)
(home-page "http://www.mpfr.org/")))
@@ -119,34 +122,38 @@ floating-point computations with correct rounding.")
(outputs '("out" "debug"))
(propagated-inputs `(("gmp" ,gmp) ; <mpc.h> refers to both
("mpfr" ,mpfr)))
- (synopsis "C library for arbitrary precision complex arithmetic")
+ (synopsis "C library for arbitrary-precision complex arithmetic")
(description
- "GNU MPC is a C library for performing arithmetic on complex numbers.
-It supports arbitrarily high precision and it correctly rounds the results.")
+ "GNU@tie{}@dfn{MPC} (Multiple Precision Complex library) is a C library for
+performing arithmetic on complex numbers. It supports arbitrarily high
+precision and correctly rounds the results.")
(license lgpl3+)
- (home-page "http://mpc.multiprecision.org/")))
+ (home-page "http://multiprecision.org/mpc/")))
(define-public mpfi
(package
(name "mpfi")
- (version "1.5.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://gforge.inria.fr/frs/download.php/"
- "file/30130/mpfi-" version ".tar.gz"))
- (sha256
- (base32
- "1g2q6i7dqx40p4gw11da6jgfcbzmm26wxc69fwv8zpcdyg32a9za"))))
+ (version "1.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://gforge.inria.fr/frs/download.php"
+ "/latestfile/181/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32 "0bqr8yibl7jbrp0bw7xk1lm7nis7rv26jsz6y8ycvih8n9bx90r3"))))
(build-system gnu-build-system)
(propagated-inputs `(("gmp" ,gmp) ; <mpfi.h> refers to both
("mpfr" ,mpfr)))
- (synopsis "C library for arbitrary precision interval arithmetic")
- (description "MPFI is intended to be a portable library written in C for
-arbitrary precision interval arithmetic with intervals represented using MPFR
-reliable floating-point numbers. It is based on the GNU MP library and on the
-MPFR library. The purpose of an arbitrary precision interval arithmetic is on
-the one hand to get guaranteed results, thanks to interval computation, and on
-the other hand to obtain accurate results, thanks to multiple precision
-arithmetic.")
+ (synopsis "C library for arbitrary-precision interval arithmetic")
+ (description
+ "@dfn{MPFI} (Multiple Precision Floating-point Interval) is a portable C
+library for arbitrary-precision interval arithmetic, with intervals represented
+using MPFR reliable floating-point numbers. It's based on the @dfn{GMP} (GNU
+Multiple Precision Arithmetic) and GNU@tie{}@dfn{MPFR} (Multiple Precision
+Floating-Point Reliably) libraries.
+
+The purpose of arbitrary-precision interval arithmetic is to get results that
+are both guaranteed, thanks to interval computation, and accurate, thanks to
+multiple-precision arithmetic.")
(license lgpl2.1+)
(home-page "https://perso.ens-lyon.fr/nathalie.revol/software.html")))