summaryrefslogtreecommitdiff
path: root/gnu/packages/multiprecision.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2018-04-13 17:20:39 +0200
committerAndreas Enge <andreas@enge.fr>2018-04-13 17:20:39 +0200
commitdf131dbaf885bc7fc1464f65b6a522bfd290b09c (patch)
tree20afed65cab23bfa2c7153c227db5f3f3373e0e9 /gnu/packages/multiprecision.scm
parent0d4ea19592fb7aec9c1682c99ed0712b82cc3528 (diff)
downloadguix-patches-df131dbaf885bc7fc1464f65b6a522bfd290b09c.tar
guix-patches-df131dbaf885bc7fc1464f65b6a522bfd290b09c.tar.gz
gnu: Add iRRAM.
* gnu/packages/multiprecision.scm (irram): New variable.
Diffstat (limited to 'gnu/packages/multiprecision.scm')
-rw-r--r--gnu/packages/multiprecision.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index 4bfe0ac563..6f5c802ad4 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015, 2018 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -160,6 +160,33 @@ multiple-precision arithmetic.")
(license lgpl2.1+)
(home-page "https://perso.ens-lyon.fr/nathalie.revol/software.html")))
+(define-public irram
+ (package
+ (name "irram")
+ (version "2013_01")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://irram.uni-trier.de/irram-files/iRRAM_"
+ version ".tar.bz2"))
+ (sha256
+ (base32 "1cdmvb4hsa161rfdjqyhd9sb3fcr43p3a6nsj7cb4kn9f94qmjpj"))))
+ (build-system gnu-build-system)
+ (propagated-inputs `(("gmp" ,gmp) ; <mpfi.h> refers to both
+ ("mpfr" ,mpfr)))
+ (arguments
+ `(#:parallel-build? #f))
+ (synopsis "C++ package for real arithmetic based on the Real-RAM concept")
+ (description
+ "@dfn{iRRAM} is a C++ package for error-free real arithmetic based on
+the concept of a Real-RAM. Its capabilities range from ordinary arithmetic
+over trigonometric functions to linear algebra and differential
+equations. A program using iRRAM is coded in ordinary C++, but may use a
+special class that behaves like real numbers without any
+error. Additionally, iRRAM uses the concept of multi-valued functions.")
+ (license lgpl2.0+)
+ (home-page "http://irram.uni-trier.de/")))
+
(define-public qd
(package
(name "qd")