summaryrefslogtreecommitdiff
path: root/gnu/packages/multiprecision.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-18 17:50:42 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-18 18:07:06 +0100
commitd0d207cdca1abb97db95260c804f5b8ba963f098 (patch)
tree3a87d6087aa4c6458af5c2e2a7e96f5ded483890 /gnu/packages/multiprecision.scm
parentabd402e3a1f3856243d2956f073901fc1a4485a0 (diff)
downloadguix-patches-d0d207cdca1abb97db95260c804f5b8ba963f098.tar
guix-patches-d0d207cdca1abb97db95260c804f5b8ba963f098.tar.gz
gnu: tomsfastmath: Update to 0.13.1.
* gnu/packages/multiprecision.scm (tomsfastmath): Update to 0.13.1. [source]: Remove patch. * gnu/packages/patches/tomsfastmath-constness.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/multiprecision.scm')
-rw-r--r--gnu/packages/multiprecision.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index 969f0659a8..7ae3886166 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -230,17 +230,16 @@ and numerical quadrature programs are included.")
(define-public tomsfastmath
(package
(name "tomsfastmath")
- (version "0.13.0")
+ (version "0.13.1")
(synopsis "Large integer arithmetic library")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/libtom/tomsfastmath/"
"releases/download/v" version "/"
- "tfm-" (version-major+minor version) ".tar.bz2"))
+ "tfm-" version ".tar.xz"))
(sha256
(base32
- "01rlsvp6lskk2a0gfdi24ak5h8vdwi6kqbvbwjnmb92r0zrfdvwd"))
- (patches (search-patches "tomsfastmath-constness.patch"))))
+ "0f0pmiaskh89sp0q933pafxb914shpaj5ad8sb5rzk1wv8d7mja7"))))
(build-system gnu-build-system)
(native-inputs
`(("libtool" ,libtool)))
@@ -252,7 +251,7 @@ and numerical quadrature programs are included.")
"CC=gcc")
#:phases
(modify-phases %standard-phases
- (delete 'configure) ;no configuration
+ (delete 'configure) ; no configuration
(replace 'check
(lambda* (#:key make-flags #:allow-other-keys)
(apply invoke "make"
@@ -262,7 +261,7 @@ and numerical quadrature programs are included.")
(invoke "./test")))
(add-before 'install 'install-nogroup
(lambda _
- ;; Let permissions inherit from the current process
+ ;; Let permissions inherit from the current process.
(substitute* "makefile.shared"
(("-g \\$\\(GROUP\\) -o \\$\\(USER\\)") ""))
#t))