summaryrefslogtreecommitdiff
path: root/gnu/packages/multiprecision.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-04-21 04:57:29 -0400
committerMark H Weaver <mhw@netris.org>2018-04-21 05:02:52 -0400
commitc52872bfc418c6b2273f973dff8003ca9e062792 (patch)
tree4184a250e6d8363b3901aa2abe6910ff08ce08d4 /gnu/packages/multiprecision.scm
parent65bb22796f854cbc3eae053a80b1d64365dad376 (diff)
parent3fe49e50153fec1dabac35e262a0888044f79aa6 (diff)
downloadguix-patches-c52872bfc418c6b2273f973dff8003ca9e062792.tar
guix-patches-c52872bfc418c6b2273f973dff8003ca9e062792.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/multiprecision.scm')
-rw-r--r--gnu/packages/multiprecision.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index ee427f84eb..e185a98359 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015, 2018 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -161,6 +161,33 @@ multiple-precision arithmetic.")
(license lgpl2.1+)
(home-page "https://perso.ens-lyon.fr/nathalie.revol/software.html")))
+(define-public irram
+ (package
+ (name "irram")
+ (version "2013_01")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://irram.uni-trier.de/irram-files/iRRAM_"
+ version ".tar.bz2"))
+ (sha256
+ (base32 "1cdmvb4hsa161rfdjqyhd9sb3fcr43p3a6nsj7cb4kn9f94qmjpj"))))
+ (build-system gnu-build-system)
+ (propagated-inputs `(("gmp" ,gmp) ; <mpfi.h> refers to both
+ ("mpfr" ,mpfr)))
+ (arguments
+ `(#:parallel-build? #f))
+ (synopsis "C++ package for real arithmetic based on the Real-RAM concept")
+ (description
+ "@dfn{iRRAM} is a C++ package for error-free real arithmetic based on
+the concept of a Real-RAM. Its capabilities range from ordinary arithmetic
+over trigonometric functions to linear algebra and differential
+equations. A program using iRRAM is coded in ordinary C++, but may use a
+special class that behaves like real numbers without any
+error. Additionally, iRRAM uses the concept of multi-valued functions.")
+ (license lgpl2.0+)
+ (home-page "http://irram.uni-trier.de/")))
+
(define-public qd
(package
(name "qd")