summaryrefslogtreecommitdiff
path: root/gnu/packages/multiprecision.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-24 21:26:58 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-24 21:26:58 +0100
commit9a6b8c9fa36bca5541336d61685ebdea10654ce4 (patch)
treeb42a107e88f9d9d127e5fe16bbbcb4b71f7446f8 /gnu/packages/multiprecision.scm
parent4e3a7d84613e4caeca903a205f21707cff5819f7 (diff)
parentaa51eb2073f17e40d660d0beaeb7b1b78aa9e1cc (diff)
downloadguix-patches-9a6b8c9fa36bca5541336d61685ebdea10654ce4.tar
guix-patches-9a6b8c9fa36bca5541336d61685ebdea10654ce4.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/multiprecision.scm')
-rw-r--r--gnu/packages/multiprecision.scm62
1 files changed, 59 insertions, 3 deletions
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index fe78239c1f..3d473a9cc2 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -192,14 +192,14 @@ error. Additionally, iRRAM uses the concept of multi-valued functions.")
(define-public qd
(package
(name "qd")
- (version "2.3.18")
+ (version "2.3.22")
(source (origin
(method url-fetch)
(uri (string-append "http://crd.lbl.gov/~dhbailey/mpdist/qd-"
version ".tar.gz"))
(sha256
(base32
- "0vkihcj9fyv2cycq8515713gbs3yskhmivy8bznvx72i6ddnn2c1"))))
+ "0wpgdzjcbanwd0c9mk90n04nas0q5fwc5zkrlbxyn6yjd2n8k3i6"))))
(build-system gnu-build-system)
(native-inputs
`(("gfortran" ,gfortran)))
@@ -290,3 +290,59 @@ Libs: -L~a/lib -ltfm~%"
ISO C. It is a port of LibTomMath with optional support for inline assembler
multiplies.")
(license public-domain)))
+
+(define-public libtommath
+ (package
+ (name "libtommath")
+ (version "1.1.0")
+ (outputs '("out" "static"))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/libtom/libtommath/releases/"
+ "download/v" version "/ltm-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1bbyagqzfdbg37k1n08nsqzdf44z8zsnjjinqbsyj7rxg246qilh"))
+ (patches (search-patches "libtommath-fix-linkage.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; no configure
+ (add-after 'unpack 'prepare-build
+ (lambda _
+ ;; Don't pull in coreutils.
+ (substitute* "makefile_include.mk"
+ (("arch") "uname -m"))
+
+ ;; We want the shared library by default so force it to be the
+ ;; default makefile target.
+ (delete-file "makefile")
+ (symlink "makefile.shared" "makefile")
+ #t))
+ (add-after 'install 'remove-static-library
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file (string-append (assoc-ref outputs "out")
+ "/lib/libtommath.a"))
+ #t))
+ (replace 'check
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "test_standalone" make-flags)
+ (invoke "sh" "test")))
+ (add-after 'install 'install-static-library
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "make" "-f" "makefile.unix" "install"
+ (string-append "PREFIX=" (assoc-ref outputs "static"))
+ (string-append "CC=" (which "gcc"))))))
+ #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ "CC=gcc")))
+ (native-inputs
+ `(("libtool" ,libtool)))
+ (home-page "https://www.libtom.net/LibTomMath/")
+ (synopsis "Portable number theoretic multiple-precision integer library")
+ (description "LibTomMath is a portable number theoretic multiple-precision
+integer library written entirely in C. It's designed to provide an API that is
+simple to work with that provides fairly efficient routines that build out of
+the box without configuration.")
+ (license unlicense)))