summaryrefslogtreecommitdiff
path: root/gnu/packages/multiprecision.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/multiprecision.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/multiprecision.scm')
-rw-r--r--gnu/packages/multiprecision.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index c7307da0cf..9dbe8ee179 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -50,7 +50,7 @@
"1wml97fdmpcynsbw9yl77rj29qibfp652d0w3222zlfx5j8jjj7x"))
(patches (search-patches "gmp-faulty-test.patch"))))
(build-system gnu-build-system)
- (native-inputs `(("m4" ,m4)))
+ (native-inputs (list m4))
(outputs '("out" "debug"))
(arguments
`(#:parallel-tests? #f ; mpz/reuse fails otherwise
@@ -123,7 +123,7 @@ It is aimed at use in, for example, cryptography and computational algebra.")
"0zwaanakrqjf84lfr5hfsdr7hncwv9wj0mchlr7cmxigfgqs760c"))))
(build-system gnu-build-system)
(outputs '("out" "debug"))
- (propagated-inputs `(("gmp" ,gmp))) ; <mpfr.h> refers to <gmp.h>
+ (propagated-inputs (list gmp)) ; <mpfr.h> refers to <gmp.h>
(synopsis "C library for arbitrary-precision floating-point arithmetic")
(description
"GNU@tie{}@acronym{MPFR, Multiple Precision Floating-Point Reliably} is a C
@@ -145,8 +145,8 @@ correct rounding.")
"0n846hqfqvmsmim7qdlms0qr86f1hck19p12nq3g3z2x74n3sl0p"))))
(build-system gnu-build-system)
(outputs '("out" "debug"))
- (propagated-inputs `(("gmp" ,gmp) ; <mpc.h> refers to both
- ("mpfr" ,mpfr)))
+ (propagated-inputs (list gmp ; <mpc.h> refers to both
+ mpfr))
(synopsis "C library for arbitrary-precision complex arithmetic")
(description
"GNU@tie{}@acronym{MPC, Multiple Precision Complex library} is a C library
@@ -176,8 +176,8 @@ precision and correctly rounds the results.")
("libtool" ,libtool)
("texinfo" ,texinfo)))
(propagated-inputs
- `(("gmp" ,gmp) ; <mpfi.h> refers to both
- ("mpfr" ,mpfr)))
+ (list gmp ; <mpfi.h> refers to both
+ mpfr))
(home-page "https://gforge.inria.fr/projects/mpfi/")
(synopsis "C library for arbitrary-precision interval arithmetic")
(description
@@ -204,8 +204,8 @@ multiple-precision arithmetic.")
(sha256
(base32 "1cdmvb4hsa161rfdjqyhd9sb3fcr43p3a6nsj7cb4kn9f94qmjpj"))))
(build-system gnu-build-system)
- (propagated-inputs `(("gmp" ,gmp) ; <mpfi.h> refers to both
- ("mpfr" ,mpfr)))
+ (propagated-inputs (list gmp ; <mpfi.h> refers to both
+ mpfr))
(arguments
`(#:parallel-build? #f))
(synopsis "C++ package for real arithmetic based on the Real-RAM concept")
@@ -232,7 +232,7 @@ error. Additionally, iRRAM uses the concept of multi-valued functions.")
(base32 "1lq609rsp6zpg7zda75lyxzzk1fabzp4jn88j7xfk84mdgjgzh9h"))))
(build-system gnu-build-system)
(native-inputs
- `(("gfortran" ,gfortran)))
+ (list gfortran))
(arguments
`(#:configure-flags `("--disable-enable_fma" ;weird :/
"--enable-shared"
@@ -272,7 +272,7 @@ and numerical quadrature programs are included.")
(arguments
`(#:configure-flags (list "--disable-static")))
(inputs
- `(("gmp" ,gmp)))
+ (list gmp))
(home-page "https://www.ginac.de/CLN/")
(synopsis "Library for arbitrary precision computations")
(description "CLN is a C++ library for efficient computations with all
@@ -295,7 +295,7 @@ classes and elementary, logical and transcendental functions.")
"0f0pmiaskh89sp0q933pafxb914shpaj5ad8sb5rzk1wv8d7mja7"))))
(build-system gnu-build-system)
(native-inputs
- `(("libtool" ,libtool)))
+ (list libtool))
(arguments
`(#:make-flags (list "-f" "makefile.shared"
(string-append "LIBPATH=" %output "/lib")
@@ -408,9 +408,9 @@ multiplies.")
"/lib/libtommath.so"))
(string-append "CC=" ,(cc-for-target)))))
(native-inputs
- `(("libtool" ,libtool)))
+ (list libtool))
(inputs
- `(("libtommath" ,libtommath)))
+ (list libtommath))
(home-page "https://www.libtom.net/LibTomCrypt/")
(synopsis "Cryptographic toolkit")
(description "LibTomCrypt is a fairly comprehensive, modular and portable
@@ -463,7 +463,7 @@ number generators, public key cryptography and a plethora of other routines.")
#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
"CC=gcc")))
(native-inputs
- `(("libtool" ,libtool)))
+ (list libtool))
(home-page "https://www.libtom.net/LibTomMath/")
(synopsis "Portable number theoretic multiple-precision integer library")
(description "LibTomMath is a portable number theoretic multiple-precision