summaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-06-14 17:11:00 -0500
committerEric Bavier <bavier@member.fsf.org>2015-06-29 15:34:36 -0500
commitce7d9c989de569712b96f3bbb6c5db4d4c5595a9 (patch)
treeb1bc4bc3d57ce86298e006b288dbf2f260456eb1 /gnu/packages/mpi.scm
parent7362371da5adee0d9d44e9a4a24cbef4b7a5c529 (diff)
downloadguix-patches-ce7d9c989de569712b96f3bbb6c5db4d4c5595a9.tar
guix-patches-ce7d9c989de569712b96f3bbb6c5db4d4c5595a9.tar.gz
gnu: hwloc: Upgrade to 1.10.1.
* gnu/packages/patches/hwloc-gather-topology-lstopo.patch: New patch. * gnu/packages/mpi.scm (hwloc): Upgrade to 1.10.1. [source]: Use patch. [propagated-inputs]: Remove libpci. [inputs]: Add libpciaccess. * gnu-system.am (dist_patch_DATA): Add patch.
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm23
1 files changed, 10 insertions, 13 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 8e62da9701..0e1016e00f 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;;
@@ -39,30 +39,29 @@
(define-public hwloc
(package
(name "hwloc")
- (version "1.9")
+ (version "1.10.1")
(source (origin
(method url-fetch)
(uri (string-append "http://www.open-mpi.org/software/hwloc/v"
- version "/downloads/hwloc-"
- version ".tar.bz2"))
+ (version-major+minor version)
+ "/downloads/hwloc-" version ".tar.bz2"))
(sha256
(base32
- "0zjgiili2a8v63s8ly3a8qp8ibxv1jw3zbgm7diic3w1qgqiza14"))))
+ "0jji5rphy05s0lp6bknn8lxwixrq0hy5rjzsqvhjszbkl2li7kim"))
+ (patches (list
+ (search-patch "hwloc-gather-topology-lstopo.patch")))))
(build-system gnu-build-system)
- (arguments
- ;; Enable libpci support, which effectively makes hwloc GPLv2+.
- '(#:configure-flags '("--enable-libpci")))
(inputs
`(("libx11" ,libx11)
("cairo" ,cairo)
("ncurses" ,ncurses)
+ ("libpciaccess" ,libpciaccess)
("expat" ,expat)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(propagated-inputs
- ;; 'hwloc.pc' refers to libpci and libnuma, hence the propagation.
- `(("numactl" ,numactl)
- ("pciutils" ,pciutils)))
+ ;; 'hwloc.pc' refers to libnuma, hence the propagation.
+ `(("numactl" ,numactl)))
(home-page "http://www.open-mpi.org/projects/hwloc/")
(synopsis "Abstraction of hardware architectures")
(description
@@ -77,8 +76,6 @@ exploit it accordingly and efficiently.
hwloc may display the topology in multiple convenient formats. It also offers
a powerful programming interface to gather information about the hardware,
bind processes, and much more.")
-
- ;; But see above about linking against libpci.
(license bsd-3)))
(define-public openmpi