summaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2020-11-02 09:11:32 +0100
committerLudovic Courtès <ludo@gnu.org>2020-11-02 14:59:34 +0100
commitc73496f433044a76003b33c3855bb35ecd0df87f (patch)
treeead1f7c108509d9833281badeb6bdb2b5eaaff8d /gnu/packages/mpi.scm
parent60a9f246fa0cdc2672f468861dfe295e5d354fe3 (diff)
downloadguix-patches-c73496f433044a76003b33c3855bb35ecd0df87f.tar
guix-patches-c73496f433044a76003b33c3855bb35ecd0df87f.tar.gz
gnu: mpich: Configure to use ucx.
Suggested by Maurice Brémond <Maurice.Bremond@inria.fr>. Fixes bug when running test suites involving MPICH: <https://issues.guix.gnu.org/39588#15>. * gnu/packages/mpi.scm (mpich)[arguments]: Pass "--with-device=ch4:ucx".
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 06a82cce95..9035147441 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -436,7 +436,12 @@ arrays) that expose a buffer interface.")
`(#:configure-flags
(list "--disable-silent-rules" ;let's see what's happening
"--enable-debuginfo"
- ;; "--with-device=ch4:ucx" ; --with-device=ch4:ofi segfaults in tests
+
+ ;; Default to "ch4", as will be the case in 3.4. It also works
+ ;; around issues when running test suites of packages that use
+ ;; MPICH: <https://issues.guix.gnu.org/39588#15>.
+ "--with-device=ch4:ucx" ; --with-device=ch4:ofi segfaults in tests
+
(string-append "--with-hwloc-prefix="
(assoc-ref %build-inputs "hwloc"))