summaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2022-04-11 15:30:55 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-11 15:49:33 +0200
commitb478d55ac43b903d2c34e70839d5f3ed1b152c71 (patch)
tree96b3d18d0777c23b8f88eb7d698c4449d8bfdf16 /gnu/packages/mpi.scm
parent649556ea092ffb08277b687c791a041cc291ca1e (diff)
downloadguix-patches-b478d55ac43b903d2c34e70839d5f3ed1b152c71.tar
guix-patches-b478d55ac43b903d2c34e70839d5f3ed1b152c71.tar.gz
gnu: openmpi: Remove input labels.
* gnu/packages/mpi.scm (openmpi)[inputs]: Remove input labels.
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm38
1 files changed, 18 insertions, 20 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 389fdaa5c4..250ebb9213 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -202,26 +202,24 @@ bind processes, and much more.")
(build-system gnu-build-system)
(inputs
- `(("hwloc" ,hwloc-2 "lib")
- ("gfortran" ,gfortran)
- ("libfabric" ,libfabric)
- ("libevent" ,libevent)
- ("opensm" ,opensm)
- ,@(if (and (not (%current-target-system))
- (member (%current-system) (package-supported-systems psm)))
- `(("psm" ,psm))
- '())
- ,@(if (and (not (%current-target-system))
- (member (%current-system) (package-supported-systems psm2)))
- `(("psm2" ,psm2))
- '())
- ,@(if (and (not (%current-target-system))
- (member (%current-system) (package-supported-systems ucx)))
- `(("ucx" ,ucx))
- '())
- ("rdma-core" ,rdma-core)
- ("valgrind" ,valgrind)
- ("slurm" ,slurm))) ;for PMI support (launching via "srun")
+ (let ((if-supported
+ (lambda (package)
+ (if (and (not (%current-target-system))
+ (member (%current-system)
+ (package-supported-systems package)))
+ (list package)
+ '()))))
+ (append (list `(,hwloc-2 "lib")
+ gfortran
+ libfabric
+ libevent
+ opensm)
+ (if-supported psm)
+ (if-supported psm2)
+ (if-supported ucx)
+ (list rdma-core
+ valgrind
+ slurm)))) ;for PMI support (launching via "srun")
(native-inputs
(list pkg-config perl))
(outputs '("out" "debug"))