summaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-11-16 17:19:17 +0100
committerLudovic Courtès <ludo@gnu.org>2019-11-16 17:43:49 +0100
commitb1077c2234c47902990a6d27f471fd6b23a2df06 (patch)
treee45fd25bfbd3bb9ed8c98431f4976d74277002fd /gnu/packages/mpi.scm
parent2401806bdbc362e5c6ff03a2a3dd33a5d4cdf96e (diff)
downloadguix-patches-b1077c2234c47902990a6d27f471fd6b23a2df06.tar
guix-patches-b1077c2234c47902990a6d27f471fd6b23a2df06.tar.gz
gnu: openmpi: Silence UCX warnings when running tests.
* gnu/packages/mpi.scm (%openmpi-setup): Set "UCX_LOG_LEVEL".
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 41655a4a5c..f51e03a4d7 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -342,6 +342,15 @@ only provides @code{MPI_THREAD_FUNNELED}.")))
;; Allow oversubscription in case there are less physical cores available
;; in the build environment than the package wants while testing.
(setenv "OMPI_MCA_rmaps_base_mapping_policy" "core:OVERSUBSCRIBE")
+
+ ;; UCX sometimes outputs uninteresting warnings such as:
+ ;;
+ ;; mpool.c:38 UCX WARN object 0x7ffff44fffc0 was not returned to mpool ucp_am_bufs
+ ;;
+ ;; These in turn leads to failures of test suites that capture and
+ ;; compare stdout, such as that of 'hdf5-parallel-openmpi'. Thus, tell
+ ;; UCX to not emit those warnings.
+ (setenv "UCX_LOG_LEVEL" "error")
#t))
(define-public intel-mpi-benchmarks