summaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-05-25 12:11:41 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-25 13:43:03 +0200
commita560641a604c4766acfa2ff015a10c9465a721eb (patch)
treedd5da627c9c6db7aa8480386b7315cd6596cada3 /gnu/packages/mpi.scm
parent6df2a50ac4172b7109e4b86656ffd989e98184d7 (diff)
downloadguix-patches-a560641a604c4766acfa2ff015a10c9465a721eb.tar
guix-patches-a560641a604c4766acfa2ff015a10c9465a721eb.tar.gz
gnu: openmpi: Reintroduce PSM (Intel TrueScale) support.
Fixes a regression introduced in 9129804230a3a4272731609f6418b876ba450575 whereby PSM would never be added as an input. * gnu/packages/mpi.scm (openmpi)[inputs]: Re-add PSM on supported systems.
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 5496ea9c9e..e8d28d6060 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -168,10 +168,10 @@ bind processes, and much more.")
`(("hwloc" ,hwloc "lib")
("gfortran" ,gfortran)
("libfabric" ,libfabric)
- ,@(match (%current-system)
- ((member (package-supported-systems psm))
- `(("psm" ,psm)))
- (_ `()))
+ ,@(if (and (not (%current-target-system))
+ (member (%current-system) (package-supported-systems psm)))
+ `(("psm" ,psm))
+ '())
("rdma-core" ,rdma-core)
("valgrind" ,valgrind)))
(native-inputs