summaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-11-07 20:26:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-11-07 20:41:08 +0200
commit9129804230a3a4272731609f6418b876ba450575 (patch)
tree499be2b9f45f94d22aafddd62ec559a28eae1e21 /gnu/packages/mpi.scm
parentb516b780022010d32c5746adde19c3af20ee74a3 (diff)
downloadguix-patches-9129804230a3a4272731609f6418b876ba450575.tar
guix-patches-9129804230a3a4272731609f6418b876ba450575.tar.gz
gnu: psm: Only use as an input on supported-systems.
Syntax help supplied by bavier@member.fsf.org * gnu/packages/linux.scm (libfabric)[inputs]: Only use psm as an input on systems where psm is supported. * gnu/packages/mpi.scm (openmpi)[inputs]: Same.
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 5054fa9d9c..d9a2094bea 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Dave Love <fx@gnu.org>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,7 +38,8 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
- #:use-module (gnu packages valgrind))
+ #:use-module (gnu packages valgrind)
+ #:use-module (ice-9 match))
(define-public hwloc
(package
@@ -126,7 +128,10 @@ bind processes, and much more.")
`(("hwloc" ,hwloc "lib")
("gfortran" ,gfortran)
("libfabric" ,libfabric)
- ("psm" ,psm)
+ ,@(match (%current-system)
+ ((member (package-supported-systems psm))
+ `(("psm" ,psm)))
+ (_ `()))
("rdma-core" ,rdma-core)
("valgrind" ,valgrind)))
(native-inputs