summaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-12-20 22:35:12 +0100
committerLudovic Courtès <ludo@gnu.org>2019-12-20 22:35:12 +0100
commit2d6f68aa3b0404c3c37568a8a7bfee692cb80337 (patch)
tree250e6a5c2a33d1849f091a36fefc89a114b772a0 /gnu/packages/mpi.scm
parentf94f9d67e65975724ee5b5cbc936c0895a258685 (diff)
downloadguix-patches-2d6f68aa3b0404c3c37568a8a7bfee692cb80337.tar
guix-patches-2d6f68aa3b0404c3c37568a8a7bfee692cb80337.tar.gz
gnu: intel-mpi-benchmarks: Merge with "imb-openmpi".
* gnu/packages/mpi.scm (intel-mpi-benchmarks): Remove. * gnu/packages/benchmark.scm (imb): Rename to... (intel-mpi-benchmarks): ... this. Change 'name'. Update to 2019.3. [arguments]: Remove 'build phase. Rewrite 'install phase. Pass #:parallel-build? and #:make-flags. (intel-mpi-benchmarks/openmpi): New variable. (imb-openmpi): Rewrite in terms of 'deprecated-package'.
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm52
1 files changed, 0 insertions, 52 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 45941df0b0..55641d8fa1 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -29,7 +29,6 @@
#:use-module ((guix licenses)
#:hide (expat))
#:use-module (guix download)
- #:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix deprecation)
#:use-module (guix build-system gnu)
@@ -357,57 +356,6 @@ only provides @code{MPI_THREAD_FUNNELED}.")))
(setenv "UCX_LOG_LEVEL" "error")
#t))
-(define-public intel-mpi-benchmarks
- (package
- (name "intel-mpi-benchmarks")
- (version "2019.3")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/intel/mpi-benchmarks.git")
- (commit (string-append "IMB-v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0si5xi6ilhd3w0gbsg124589pvp094hvf366rvjjb9pi7pdk5p4i"))))
- (build-system gnu-build-system)
- (arguments
- '(#:phases (modify-phases %standard-phases
- (delete 'configure)
- (delete 'check)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (define (benchmark? file stat)
- (and (string-prefix? "IMB-" (basename file))
- (executable-file? file)))
-
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (for-each (lambda (file)
- (install-file file bin))
- (find-files "." benchmark?))
- #t))))
-
- ;; The makefile doesn't express all the dependencies, it seems.
- #:parallel-build? #t
-
- #:make-flags (list (string-append "CC="
- (assoc-ref %build-inputs "openmpi")
- "/bin/mpicc")
- (string-append "CXX="
- (assoc-ref %build-inputs "openmpi")
- "/bin/mpicxx"))))
- (inputs
- `(("openmpi" ,openmpi)))
- (home-page "https://github.com/intel/mpi-benchmarks")
- (synopsis "Benchmarks for the Message Passing Interface (MPI)")
- (description
- "Intel MPI Benchmarks (IMB) provides a set of elementary benchmarks that
-conform with versions 1, 2, and 3 of the Message Passing Interface (MPI).")
- (license
- (fsf-free "https://directory.fsf.org/wiki/License:CPL-1.0"
- "https://www.gnu.org/licenses/license-list.html#CommonPublicLicense10"))))
-
(define-public python-mpi4py
(package
(name "python-mpi4py")