summaryrefslogtreecommitdiff
path: root/gnu/packages/mpi.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2018-04-10 14:29:33 +0200
committerLudovic Courtès <ludo@gnu.org>2018-04-10 17:44:27 +0200
commit10de06bd07eca266bdd59333cb671682af70fdcc (patch)
tree54407c8f6f393c239eedb444d8bf9561deed050d /gnu/packages/mpi.scm
parenta69e0cf3ca84079a6e1765040e9dee5e2858bf9f (diff)
downloadguix-patches-10de06bd07eca266bdd59333cb671682af70fdcc.tar
guix-patches-10de06bd07eca266bdd59333cb671682af70fdcc.tar.gz
gnu: hwloc: Skip 'linux-libnuma' test.
That test would fail on some machines, for instance build machines behind berlin.guixsd.org. * gnu/packages/mpi.scm (hwloc)[arguments]: Add 'skip-linux-libnuma-test' phase. (hwloc-2.0)[arguments]: Replace it.
Diffstat (limited to 'gnu/packages/mpi.scm')
-rw-r--r--gnu/packages/mpi.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index e4c1a491c3..5dfb26ae75 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -79,6 +79,14 @@
`(#:configure-flags '("--localstatedir=/var")
#:phases
(modify-phases %standard-phases
+ (add-before 'check 'skip-linux-libnuma-test
+ (lambda _
+ ;; Arrange to skip 'tests/linux-libnuma', which fails on some
+ ;; machines: <https://github.com/open-mpi/hwloc/issues/213>.
+ (substitute* "tests/linux-libnuma.c"
+ (("numa_available\\(\\)")
+ "-1"))
+ #t))
(add-after 'install 'refine-libnuma
;; Give -L arguments for libraries to avoid propagation
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -128,7 +136,19 @@ bind processes, and much more.")
"0jf0krj1h95flmb784ifv9vnkdnajjz00p4zbhmja7vm4v67axdr"))))
;; libnuma is no longer needed.
- (inputs (alist-delete "numactl" (package-inputs hwloc)))))
+ (inputs (alist-delete "numactl" (package-inputs hwloc)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments hwloc)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (replace 'skip-linux-libnuma-test
+ (lambda _
+ ;; Arrange to skip 'tests/hwloc/linux-libnuma', which fails on
+ ;; some machines: <https://github.com/open-mpi/hwloc/issues/213>.
+ (substitute* "tests/hwloc/linux-libnuma.c"
+ (("numa_available\\(\\)")
+ "-1"))
+ #t))))))))
(define-public openmpi
(package