summaryrefslogtreecommitdiff
path: root/gnu/packages/mpd.scm
diff options
context:
space:
mode:
authorEvan Straw <evan.straw99@gmail.com>2019-11-22 18:52:36 -0800
committerLeo Famulari <leo@famulari.name>2019-11-23 15:58:41 -0500
commit5ce0aab3fb953e15e9319d356a2caf636ef219d8 (patch)
tree9de5e8e333d723518f5c78ddcf14e3e3a2d9f696 /gnu/packages/mpd.scm
parent1e8609f2387905c06c42d0efe9d08391ca9354ea (diff)
downloadguix-patches-5ce0aab3fb953e15e9319d356a2caf636ef219d8.tar
guix-patches-5ce0aab3fb953e15e9319d356a2caf636ef219d8.tar.gz
gnu: Add ashuffle.
* gnu/packages/mpd.scm (ashuffle): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/mpd.scm')
-rw-r--r--gnu/packages/mpd.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index c9a9c440d3..65535062c9 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2016, 2018, 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Evan Straw <evan.straw99@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,6 +28,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
@@ -340,3 +342,27 @@ Daemon (MPD). It supports playlists, multiple profiles (connecting to different
MPD servers, search and multimedia key support.")
(home-page "https://www.nongnu.org/sonata/")
(license license:gpl3+)))
+
+(define-public ashuffle
+ (package
+ (name "ashuffle")
+ (version "2.0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/joshkunz/ashuffle.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11aa95cg0yca2m2d00sar6wr14g3lc7cfm9bin1h7lk7asdm8azp"))))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("libmpdclient" ,libmpdclient)))
+ (build-system meson-build-system)
+ (home-page "https://github.com/joshkunz/ashuffle")
+ (synopsis "Automatic library-wide shuffle for mpd")
+ (description "ashuffle is an application for automatically shuffling your
+MPD library in a similar way to many other music player's 'shuffle library'
+feature. ashuffle works like any other MPD client, and can be used alongside
+other MPD frontends.")
+ (license license:expat)))