summaryrefslogtreecommitdiff
path: root/gnu/packages/mpd.scm
diff options
context:
space:
mode:
authorNoah Evans <noah@nevans.me>2021-01-10 15:39:40 -0500
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-01-11 12:48:02 +0100
commit1a1d358f2877004125235dc57b19aaace4e2c109 (patch)
treeb8a90809cfd9fb8182d1520b535250d628ed1629 /gnu/packages/mpd.scm
parent21cf0d36db9f02b3da976088b5ab466822d16625 (diff)
downloadguix-patches-1a1d358f2877004125235dc57b19aaace4e2c109.tar
guix-patches-1a1d358f2877004125235dc57b19aaace4e2c109.tar.gz
gnu: Add mcg.
* gnu/packages/mpd.scm (mcg): New variable. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/mpd.scm')
-rw-r--r--gnu/packages/mpd.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 6066913f16..3b76b5502a 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Lars-Dominik Braun <lars@6xq.net>
;;; Copyright © 2020 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2021 Noah Evans <noah@nevans.me>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -460,3 +461,56 @@ of the music library will be created to provide a hierarchy of albums and
artists along with albumart.")
(home-page "https://github.com/cdrummond/cantata")
(license license:gpl3+)))
+
+(define-public mcg
+ (package
+ (name "mcg")
+ (version "2.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://gitlab.com/coderkun/mcg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01iqxydssxyi4s644dwl64vm7xhn0szd99hdpywbipvb7kwp5196"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("avahi" ,avahi)
+ ("dconf" ,dconf)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gtk+" ,gtk+)
+ ("python-pygobject" ,python-pygobject)))
+ (arguments
+ `(#:imported-modules ((guix build glib-or-gtk-build-system)
+ ,@%python-build-system-modules)
+ #:modules ((guix build python-build-system)
+ ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
+ (guix build utils))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/mcg")))
+ (wrap-program prog
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH")))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
+ #t)))
+ (add-after 'wrap-program 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
+ (synopsis "Covergrid for the MPD")
+ (description
+ "mcg (CoverGrid) is a client for the Music Player Daemon (MPD), focusing
+on albums instead of single tracks. It is not intended to be a replacement
+for your favorite MPD client but an addition to get a better
+album-experience.")
+ (home-page "https://gitlab.com/coderkun/mcg")
+ (license license:gpl3+)))