summaryrefslogtreecommitdiff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-07 11:04:44 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-07 14:19:08 +0200
commitd9dfbf886ddbb92dfdaa118bb9765e78aad5c53a (patch)
tree2732020de20a38c09b66a60b0cb36022799f7c2e /gnu/packages/mp3.scm
parentb949f34f31a045eb0fb242b81a223178fb6994d3 (diff)
parent49922efb11da0f0e9d4f5979d081de5ea8c99d25 (diff)
downloadguix-patches-d9dfbf886ddbb92dfdaa118bb9765e78aad5c53a.tar
guix-patches-d9dfbf886ddbb92dfdaa118bb9765e78aad5c53a.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm22
1 files changed, 19 insertions, 3 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index a2f1c0e6e8..bb9c07bc9d 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -645,19 +646,34 @@ FFmpeg, etc.")
(define-public python-pyacoustid
(package
(name "python-pyacoustid")
- (version "1.1.7")
+ (version "1.2.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyacoustid" version))
(sha256
(base32
- "1zan6c22ca6sjy0g9ajwjp6mkzw7jv8r3n7jzska09a6x254lf87"))))
+ "0ha15m41r8ckmanc4k9nrlb9hprvhdjxndzw40a1yj3z1b1xjyf2"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chromaprint-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "chromaprint.py"
+ (("libchromaprint.so.1")
+ (string-append (assoc-ref inputs "chromaprint")
+ "/lib/libchromaprint.so.1")))
+ (substitute* "acoustid.py"
+ (("'fpcalc'")
+ (string-append "'" (assoc-ref inputs "chromaprint")
+ "/bin/fpcalc'")))
+ #t)))))
+ (inputs `(("chromaprint" ,chromaprint)))
(propagated-inputs
`(("python-audioread" ,python-audioread)
("python-requests" ,python-requests)))
- (home-page "https://github.com/sampsyo/pyacoustid")
+ (home-page "https://github.com/beetbox/pyacoustid")
(synopsis "Bindings for Chromaprint acoustic fingerprinting")
(description
"This package provides bindings for the Chromaprint acoustic