summaryrefslogtreecommitdiff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-02-02 00:03:37 +0100
committerAndreas Enge <andreas@enge.fr>2013-02-04 11:12:32 +0100
commitd464e72566ca3fe4cec9786921501e271054fd45 (patch)
treeb24ff1aaa7c32390c91ad7a8ee715b219d56da19 /gnu/packages/mp3.scm
parent0f3d2504f75595a2db2a2344b624ced2ba307448 (diff)
downloadguix-patches-d464e72566ca3fe4cec9786921501e271054fd45.tar
guix-patches-d464e72566ca3fe4cec9786921501e271054fd45.tar.gz
gnu: Add libmad.
* gnu/packages/mp3.scm: New file. * Makefile.am (MODULES): Add it.
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm61
1 files changed, 61 insertions, 0 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
new file mode 100644
index 0000000000..c5a13aa7c6
--- /dev/null
+++ b/gnu/packages/mp3.scm
@@ -0,0 +1,61 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages mp3)
+ #:use-module ((guix licenses)
+ #:renamer (symbol-prefix-proc 'license:))
+ #:use-module (gnu packages autotools)
+ #:use-module (gnu packages oggvorbis)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu))
+
+(define-public libmad
+ (package
+ (name "libmad")
+ (version "0.15.1b")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/mad/libmad/"
+ version "/libmad-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "14460zhacxhswnzb36qfpd1f2wbk10qvksvm6wyq5hpvdgnw7ymv"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key #:allow-other-keys #:rest args)
+ (let ((configure (assoc-ref %standard-phases 'configure)))
+ ;; remove option that is not supported by gcc any more
+ (substitute* "configure" ((" -fforce-mem") ""))
+ (apply configure args)))
+ %standard-phases)))
+ (synopsis "libmad, an MPEG audio decoder")
+ (description
+ "MAD (MPEG Audio Decoder) supports MPEG-1 and the MPEG-2 extension to
+lower sampling frequencies, as well as the de facto MPEG 2.5 format.
+All three audio layers — Layer I, Layer II, and Layer III (i.e. MP3) — are
+fully implemented.
+
+This package contains the library.")
+ (license license:gpl2+)
+ (home-page "http://www.underbit.com/products/mad/")))
+