summaryrefslogtreecommitdiff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2017-11-21 09:49:35 +0000
committerMarius Bakke <mbakke@fastmail.com>2017-11-21 22:18:44 +0100
commitd1451fa0d0b27a20ef3a1b3fe8d53a995f0c4d85 (patch)
tree156b5e719e43ceaf9997e3808f288bd54a18f9b3 /gnu/packages/mp3.scm
parentd280a0faeaba67be03a37b49a300bafb5b9a3e8f (diff)
downloadguix-patches-d1451fa0d0b27a20ef3a1b3fe8d53a995f0c4d85.tar
guix-patches-d1451fa0d0b27a20ef3a1b3fe8d53a995f0c4d85.tar.gz
gnu: taglib: Update to 1.11.1 and fix home page.
* gnu/packages/mp3.scm (taglib)[version]: Update to 1.11.1. [arguments]: Configure with -DBUILD_SHARED_LIBS=ON. [home-page]: Change to http://taglib.org. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 1860997e09..fbb924ba51 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
+;;; Copyright © 2017 Pierre Langlois <pierre.langlois@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -151,18 +152,20 @@ a highly stable and efficient implementation.")
(define-public taglib
(package
(name "taglib")
- (version "1.10")
+ (version "1.11.1")
(source (origin
(method url-fetch)
(uri (string-append "http://taglib.github.io/releases/taglib-"
version ".tar.gz"))
(sha256
(base32
- "1alv6vp72p0x9i9yscmz2a71anjwqy53y9pbcbqxvc1c0i82vhr4"))))
+ "0ssjcdjv4qf9liph5ry1kngam1y7zp8fzr9xv4wzzrma22kabldn"))))
(build-system cmake-build-system)
- (arguments '(#:tests? #f)) ;no 'test' target
+ (arguments
+ '(#:tests? #f ; Tests are not ran with BUILD_SHARED_LIBS on.
+ #:configure-flags (list "-DBUILD_SHARED_LIBS=ON")))
(inputs `(("zlib" ,zlib)))
- (home-page "http://developer.kde.org/~wheeler/taglib.html")
+ (home-page "http://taglib.org")
(synopsis "Library to access audio file meta-data")
(description
"TagLib is a C++ library for reading and editing the meta-data of several