summaryrefslogtreecommitdiff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-07-27 23:32:54 -0400
committer宋文武 <iyzsong@member.fsf.org>2022-08-03 13:59:37 +0800
commitcb14d802aef0aaa475147e0a5cc36ff71e631a62 (patch)
treea497ab21ba54aeab1981a7b4ade1484916c5d6dd /gnu/packages/mp3.scm
parentbf74f708d35b704ad2ead82890fb3dde50849d56 (diff)
downloadguix-patches-cb14d802aef0aaa475147e0a5cc36ff71e631a62.tar
guix-patches-cb14d802aef0aaa475147e0a5cc36ff71e631a62.tar.gz
gnu: Add minimp3.
* gnu/packages/mp3.scm (minimp3): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 4a8bdad711..275468d343 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,6 +55,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix utils)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (guix build-system cmake))
@@ -247,6 +249,35 @@ Speex, WavPack TrueAudio, WAV, AIFF, MP4 and ASF files.")
;; Dual-licensed: user may choose between LGPLv2.1 or MPLv1.1.
(license (list license:lgpl2.1 license:mpl1.1))))
+(define-public minimp3
+ ;; The latest commit is used as there is no release.
+ (let ((commit "afb604c06bc8beb145fecd42c0ceb5bda8795144")
+ (revision "0"))
+ (package
+ (name "minimp3")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lieff/minimp3")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0brgrbij8swhp7lac21xnnrr5l0371lkr5vz6h9x0dbz1qq2xhsj"))))
+ ;; TODO: minimp3 has many more files for at least tests with scripts to
+ ;; run them, although it is unclear how to easily package them.
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("minimp3.h" "include/")
+ ("minimp3_ex.h" "include/"))))
+ (home-page "https://github.com/lieff/minimp3")
+ (synopsis "Minimalistic MP3 decoder header library")
+ (description
+ "Minimp3 is a header-only MP3 decoder library.")
+ (license license:cc0))))
+
(define-public mp3info
(package
(name "mp3info")