summaryrefslogtreecommitdiff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2020-08-18 18:59:00 +0100
committerPierre Langlois <pierre.langlois@gmx.com>2020-09-04 12:04:43 +0100
commit89e1e4481382d18033a9773b90c09345fa33d6cb (patch)
tree1325b4e2c639cb9feea3e185464046fd894f03bc /gnu/packages/mp3.scm
parent235093fec0daf3563e21036d74c250d4770ffc77 (diff)
downloadguix-patches-89e1e4481382d18033a9773b90c09345fa33d6cb.tar
guix-patches-89e1e4481382d18033a9773b90c09345fa33d6cb.tar.gz
gnu: taglib: Update to 1.12-beta-1 [security fixes].
This switches to a yet unreleased version of taglib, to make sure long standings issues and CVEs are covered until a proper release is made upstream. Among these, we have: - CVE-2017-12678 - CVE-2018-11439 - https://github.com/taglib/taglib/issues/864 * gnu/packges/mp3.scm (taglib): Update to 1.12-beta-1. [source]: Switch to using git-fetch.
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 92e3d5d5f8..7ee009df74 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
-;;; Copyright © 2017, 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2017, 2019, 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
@@ -50,6 +50,7 @@
#:use-module (gnu packages video) ;ffmpeg
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
@@ -160,14 +161,16 @@ a highly stable and efficient implementation.")
(define-public taglib
(package
(name "taglib")
- (version "1.11.1")
+ (version "1.12-beta-1")
(source (origin
- (method url-fetch)
- (uri (string-append "http://taglib.github.io/releases/taglib-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/taglib/taglib")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0ssjcdjv4qf9liph5ry1kngam1y7zp8fzr9xv4wzzrma22kabldn"))))
+ "1mp6w2ikniw8w6d5wr0h20j0ijg8jw7s9dli5a8k9znpznvxpym4"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; Tests are not ran with BUILD_SHARED_LIBS on.