summaryrefslogtreecommitdiff
path: root/gnu/packages/mono.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-11-27 00:23:03 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-11-27 00:36:47 +0100
commitbc0d24292d776826b8ce9c9aa9d620e33160d1ed (patch)
tree3a14f68aa14b4f6bd1c084016953627491e2868a /gnu/packages/mono.scm
parent8160baf8b755cc6217ac263a61724c789fcf49e8 (diff)
downloadguix-patches-bc0d24292d776826b8ce9c9aa9d620e33160d1ed.tar
guix-patches-bc0d24292d776826b8ce9c9aa9d620e33160d1ed.tar.gz
gnu: mono: Make build reproducible.
* gnu/packages/patches/mono-mdoc-timestamping.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/mono.scm (mono)[source]: Use patch. [arguments]<#:phases>[make-reproducible]: New phase. <#:phases>[set-env]: Set SOURCE_DATE_EPOCH.
Diffstat (limited to 'gnu/packages/mono.scm')
-rw-r--r--gnu/packages/mono.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/mono.scm b/gnu/packages/mono.scm
index 8ab449dd8e..17f90fe30a 100644
--- a/gnu/packages/mono.scm
+++ b/gnu/packages/mono.scm
@@ -41,7 +41,8 @@
".tar.bz2"))
(sha256
(base32
- "0jibyvyv2jy8dq5ij0j00iq3v74r0y90dcjc3dkspcfbnn37cphn"))))
+ "0jibyvyv2jy8dq5ij0j00iq3v74r0y90dcjc3dkspcfbnn37cphn"))
+ (patches (search-patches "mono-mdoc-timestamping.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -52,10 +53,18 @@
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'make-reproducible
+ (lambda _
+ (substitute* "mono/mini/Makefile.in"
+ (("build_date = [^;]*;")
+ "build_date = (void*) 0;"))
+ #t))
(add-after 'unpack 'set-env
(lambda _ ;;* (#:key inputs #:allow-other-keys)
;; all tests under mcs/class fail trying to access $HOME
(setenv "HOME" "/tmp")
+ ;; ZIP files have "DOS time" which starts in Jan 1980.
+ (setenv "SOURCE_DATE_EPOCH" "315532800")
#t))
(add-after 'unpack 'fix-includes
(lambda _