summaryrefslogtreecommitdiff
path: root/gnu/packages/monitoring.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-18 04:31:08 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-18 05:41:57 +0100
commitde22cfcce1ac8309d460c13ffdc8190742edf252 (patch)
tree14ca5c8938dcf361f921f34d33ce688adb562996 /gnu/packages/monitoring.scm
parent4c3a1f0399750ecc3964ef551fff4016ca3b2b32 (diff)
downloadguix-patches-de22cfcce1ac8309d460c13ffdc8190742edf252.tar
guix-patches-de22cfcce1ac8309d460c13ffdc8190742edf252.tar.gz
gnu: fswatch: Omit static library.
* gnu/packages/monitoring.scm (fswatch)[arguments]: Add "--disable-static" to #:configure-flags.
Diffstat (limited to 'gnu/packages/monitoring.scm')
-rw-r--r--gnu/packages/monitoring.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index b7ddc208f6..69cddfceb1 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -27,6 +27,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages monitoring)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -557,6 +558,9 @@ devices.")
(build-system gnu-build-system)
(native-inputs
(list autoconf automake gettext-minimal libtool))
+ (arguments
+ (list #:configure-flags
+ #~(list "--disable-static")))
(synopsis "File system monitor")
(description "This package provides a file system monitor.")
(home-page "https://github.com/emcrisostomo/fswatch")