summaryrefslogtreecommitdiff
path: root/gnu/packages/monitoring.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-21 20:06:18 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 09:34:13 +0200
commitb5801efaa33af9b46274b67807d4e665b2b685c1 (patch)
tree42589e6c30cb1d8146eb886fe2e74e161d8a4e77 /gnu/packages/monitoring.scm
parent59625e3cc9fb0355b5c0612065d3361ebf35f0c2 (diff)
downloadguix-patches-b5801efaa33af9b46274b67807d4e665b2b685c1.tar
guix-patches-b5801efaa33af9b46274b67807d4e665b2b685c1.tar.gz
gnu: Add python-statsd.
* gnu/packages/monitoring.scm (python-statsd): New variable.
Diffstat (limited to 'gnu/packages/monitoring.scm')
-rw-r--r--gnu/packages/monitoring.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 1694f94b98..c14d62c312 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2022 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -743,3 +744,21 @@ snapshots, without displaying anything. When put into the foreground again,
display resumes.
@end itemize")
(license license:bsd-2)))
+
+(define-public python-statsd
+ (package
+ (name "python-statsd")
+ (version "3.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "statsd" version))
+ (sha256
+ (base32
+ "07yxnlalvcglgwa9pjs1clwrmwx7a4575jai7q05jz3g4i6dprp3"))))
+ (build-system python-build-system)
+ (native-inputs (list python-mock python-nose))
+ (home-page "https://github.com/jsocol/pystatsd")
+ (synopsis "Simple StatsD client")
+ (description "StatsD is a friendly front-end to Graphite. This package
+provides a simple Python client for the StatsD daemon.")
+ (license license:expat)))