summaryrefslogtreecommitdiff
path: root/gnu/packages/monitoring.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-09-02 10:11:57 +0200
committerMarius Bakke <marius@gnu.org>2020-09-22 18:41:59 +0200
commit94e7335e904138ebd5a8423cf2da278902fa03ae (patch)
treed8c63eaa6895ae1326c1dc2f412d3f057244f507 /gnu/packages/monitoring.scm
parentd7922f488b658b1adb5aff09f04a9bed0221aee1 (diff)
downloadguix-patches-94e7335e904138ebd5a8423cf2da278902fa03ae.tar
guix-patches-94e7335e904138ebd5a8423cf2da278902fa03ae.tar.gz
gnu: python2-graphite-web: Update to 1.1.7.
* gnu/packages/monitoring.scm (python2-graphite-web): Rename to ... (graphite-web): ... this. Update to 1.1.7. [arguments]: Add #:tests?. Adjust setup.py substitution. [propagated-inputs]: Use the Python 3 versions of all inputs. Use PYTHON-DJANGO-2.2 instead of PYTHON-DJANGO. [home-page]: Use HTTPS. (python2-graphite-web): Deprecate variable.
Diffstat (limited to 'gnu/packages/monitoring.scm')
-rw-r--r--gnu/packages/monitoring.scm39
1 files changed, 21 insertions, 18 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 16de32b306..30fe61ea00 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -330,49 +330,52 @@ caching them in memory for \"hot queries\" from the Graphite-Web application,
and persisting them to disk using the Whisper time-series library.")
(license license:asl2.0)))
-(define-public python2-graphite-web
+(define-public graphite-web
(package
- (name "python2-graphite-web")
- (version "1.0.2")
+ (name "graphite-web")
+ (version "1.1.7")
(source
(origin
(method url-fetch)
(uri (pypi-uri "graphite-web" version))
(sha256
(base32
- "0q8bwlj75jqyzmazfsi5sa26xl58ssa8wdxm2l4j0jqyn8xpfnmc"))))
+ "1l5a5rry9cakqxamvlx4xq63jifmncb6815bg9vy7fg1zyd3pjxk"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2 ; only supports Python 2
+ `(#:tests? #f ;XXX: not in PyPI release & requires database
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'relax-requirements
(lambda _
(substitute* "setup.py"
- (("0.4.3") ,(package-version python2-django-tagging))
- (("<1.9.99") (string-append "<="
- ,(package-version python2-django))))
+ ;; Allow newer versions of django-tagging.
+ (("django-tagging==")
+ "django-tagging>="))
#t))
;; Don't install to /opt
(add-after 'unpack 'do-not-install-to-/opt
(lambda _ (setenv "GRAPHITE_NO_PREFIX" "1") #t)))))
(propagated-inputs
- `(("python2-cairocffi" ,python2-cairocffi)
- ("python2-pytz" ,python2-pytz)
- ("python2-whisper" ,python2-whisper)
- ("python2-django" ,python2-django)
- ("python2-django-tagging" ,python2-django-tagging)
- ("python2-scandir" ,python2-scandir)
- ("python2-urllib3" ,python2-urllib3)
- ("python2-pyparsing" ,python2-pyparsing)
- ("python2-txamqp" ,python2-txamqp)))
- (home-page "http://graphiteapp.org/")
+ `(("python-cairocffi" ,python-cairocffi)
+ ("python-pytz" ,python-pytz)
+ ("python-whisper" ,python-whisper)
+ ("python-django" ,python-django-2.2)
+ ("python-django-tagging" ,python-django-tagging)
+ ("python-scandir" ,python-scandir)
+ ("python-urllib3" ,python-urllib3)
+ ("python-pyparsing" ,python-pyparsing)
+ ("python-txamqp" ,python-txamqp)))
+ (home-page "https://graphiteapp.org/")
(synopsis "Scalable realtime graphing system")
(description "Graphite is a scalable real-time graphing system that does
two things: store numeric time-series data, and render graphs of this data on
demand.")
(license license:asl2.0)))
+(define-public python2-graphite-web
+ (deprecated-package "python2-graphite-web" graphite-web))
+
(define-public python-prometheus-client
(package
(name "python-prometheus-client")