summaryrefslogtreecommitdiff
path: root/gnu/packages/monitoring.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius.bakke@usit.uio.no>2021-02-06 10:40:54 +0100
committerMarius Bakke <marius@gnu.org>2021-02-06 13:13:57 +0100
commit8bde37b03f3a5b6b76ea2b525b97d445b505d684 (patch)
tree15a35aaa420cc1e2a4964dbab81ce9d5508991d4 /gnu/packages/monitoring.scm
parentd9a7727d37648d150200032f320ac1e7c1a00a1e (diff)
downloadguix-patches-8bde37b03f3a5b6b76ea2b525b97d445b505d684.tar
guix-patches-8bde37b03f3a5b6b76ea2b525b97d445b505d684.tar.gz
gnu: Add python-pyzabbix.
* gnu/packages/monitoring.scm (python-pyzabbix): New public variable.
Diffstat (limited to 'gnu/packages/monitoring.scm')
-rw-r--r--gnu/packages/monitoring.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index f670eaa0e1..75a422921c 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -282,6 +282,45 @@ monitoring system. It can configure and display various aspects of Zabbix
through a text-based interface.")
(license license:gpl3+)))
+(define-public python-pyzabbix
+ (package
+ (name "python-pyzabbix")
+ (version "0.8.2")
+ (home-page "http://github.com/lukecyca/pyzabbix")
+ ;; No tests on PyPI, use the git checkout.
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15rrnpkv94wx6748hh4sd120v6x25rkbd6vlz6hfrhvjwxz5lgjl"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ ;; Permit newer versions of httpretty.
+ (substitute* "setup.py"
+ (("httpretty<0\\.8\\.7")
+ "httpretty"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "python" "setup.py" "nosetests")
+ (format #t "test suite not run~")))))))
+ (native-inputs
+ `(;; For tests.
+ ("python-httpretty" ,python-httpretty)
+ ("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-requests" ,python-requests)))
+ (synopsis "Python interface to the Zabbix API")
+ (description
+ "@code{pyzabbix} is a Python module for working with the Zabbix API.")
+ (license license:lgpl2.1+)))
+
(define-public darkstat
(package
(name "darkstat")