summaryrefslogtreecommitdiff
path: root/gnu/packages/monitoring.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-20 00:49:05 -0400
committerMark H Weaver <mhw@netris.org>2018-03-20 00:49:05 -0400
commit647888845c0d7b9ea1b51a3e3492d4d2382f4468 (patch)
treebe34c5ec88db452c63253dc4a15f9f4cf199b1e6 /gnu/packages/monitoring.scm
parentfe15613cdf8623574ce64c05416dd3fab41eef86 (diff)
parentc657716ede8932da356635802534aa13205a6ecd (diff)
downloadguix-patches-647888845c0d7b9ea1b51a3e3492d4d2382f4468.tar
guix-patches-647888845c0d7b9ea1b51a3e3492d4d2382f4468.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/monitoring.scm')
-rw-r--r--gnu/packages/monitoring.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index fee9575bb9..bbfa4957fc 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -28,6 +28,7 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages admin)
#:use-module (gnu packages base)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages django)
#:use-module (gnu packages gd)
@@ -264,3 +265,33 @@ and persisting them to disk using the Whisper time-series library.")
two things: store numeric time-series data, and render graphs of this data on
demand.")
(license license:asl2.0)))
+
+(define-public python-prometheus-client
+ (package
+ (name "python-prometheus-client")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "prometheus_client" version))
+ (sha256
+ (base32
+ "164qzzg8q8awqk0angcm87p2sjiibaj1wgjz0xk6j0klvqi5q2mz"))))
+ (build-system python-build-system)
+ (arguments
+ '(;; No included tests.
+ #:tests? #f))
+ (home-page
+ "https://github.com/prometheus/client_python")
+ (synopsis "Python client for the Prometheus monitoring system")
+ (description
+ "The @code{prometheus_client} package supports exposing metrics from
+software written in Python, so that they can be scraped by a Prometheus
+service.
+
+Metrics can be exposed through a standalone web server, or through Twisted,
+WSGI and the node exporter textfile collector.")
+ (license license:asl2.0)))
+
+(define-public python2-prometheus-client
+ (package-with-python2 python-prometheus-client))