summaryrefslogtreecommitdiff
path: root/gnu/packages/monitoring.scm
diff options
context:
space:
mode:
authorRaphaël Mélotte <raphael.melotte@mind.be>2021-09-01 22:43:35 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-03 22:15:38 +0200
commit45bb347099c638a6c480bbabd723c546da09219b (patch)
tree86c5019997012f35d5e45cf14a30fd2cc31117cd /gnu/packages/monitoring.scm
parentc017e0b62c3cb42a46db7f7603b63bb17c966e4a (diff)
downloadguix-patches-45bb347099c638a6c480bbabd723c546da09219b.tar
guix-patches-45bb347099c638a6c480bbabd723c546da09219b.tar.gz
gnu: Add fatrace.
* gnu/packages/monitoring.scm (fatrace): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/monitoring.scm')
-rw-r--r--gnu/packages/monitoring.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index d2aef0eaab..46dea5eeb8 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -650,3 +651,35 @@ LAN, if wanted, and clients can switch between multiple hosts on the network.
Hostscope features a bridge to Influx DB. So Grafana can be used to visualize
the recorded data over time.")
(license license:gpl3+)))
+
+(define-public fatrace
+ (package
+ (name "fatrace")
+ (version "0.16.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/martinpitt/fatrace")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1bxz6v1z0icp716jnv3knjyqp8bv6xnkz8gqd8z3g2b6yxj5xff3"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ ;; tests need root to run as root,
+ ;; and there is no make target for them:
+ (delete 'check))
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))))
+ (synopsis "File access events monitor")
+ (description "This package provides a utility to report system wide file
+access events from all running processes. Its main purpose is to find
+processes which keep waking up the disk unnecessarily and thus prevent some
+power saving.")
+ (home-page "https://github.com/martinpitt/fatrace")
+ (license license:gpl3+)))