summaryrefslogtreecommitdiff
path: root/gnu/packages/mingw.scm
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-01-25 11:51:21 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-03 10:26:22 -0500
commit88c635d96a1dfba90278dd9a3c2fcf523c74b55c (patch)
tree3ee0271e4a5f79ee1409c5eae61046eb5c1f3e78 /gnu/packages/mingw.scm
parent3d433441b10066734fbe2aebc0586d5465aeb638 (diff)
downloadguix-patches-88c635d96a1dfba90278dd9a3c2fcf523c74b55c.tar
guix-patches-88c635d96a1dfba90278dd9a3c2fcf523c74b55c.tar.gz
gnu: make-mingw-w64: Use a mirror URI and fix lint errors.
* gnu/package/mingw.scm (make-mingw-w64)[source]: Use a mirror URI. Wrap lines 80 columns to fix lint warning. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/mingw.scm')
-rw-r--r--gnu/packages/mingw.scm49
1 files changed, 27 insertions, 22 deletions
diff --git a/gnu/packages/mingw.scm b/gnu/packages/mingw.scm
index b37f6c69bd..58f01ddc9f 100644
--- a/gnu/packages/mingw.scm
+++ b/gnu/packages/mingw.scm
@@ -46,23 +46,26 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
(name (string-append "mingw-w64" "-" machine
(if with-winpthreads? "-winpthreads" "")))
(version "7.0.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://sourceforge.net/projects/mingw-w64/files/mingw-w64/"
- "mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
- (sha256
- (base32 "0a5njsa2zw2ssdz10jkb10mhrf3cb8qp9avs89zqmw4n6pzxy85a"))
- (patches
- (search-patches "mingw-w64-6.0.0-gcc.patch"
- "mingw-w64-dlltool-temp-prefix.patch"
- "mingw-w64-reproducible-gendef.patch"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/mingw-w64/mingw-w64/"
+ "mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
+ (sha256
+ (base32 "0a5njsa2zw2ssdz10jkb10mhrf3cb8qp9avs89zqmw4n6pzxy85a"))
+ (patches
+ (search-patches "mingw-w64-6.0.0-gcc.patch"
+ "mingw-w64-dlltool-temp-prefix.patch"
+ "mingw-w64-reproducible-gendef.patch"))))
(native-inputs `(("xgcc-core" ,(if xgcc xgcc (cross-gcc triplet)))
- ("xbinutils" ,(if xbinutils xbinutils (cross-binutils triplet)))
+ ("xbinutils" ,(if xbinutils xbinutils
+ (cross-binutils triplet)))
,@(if with-winpthreads?
- `(("xlibc" ,(make-mingw-w64 machine
- #:xgcc xgcc
- #:xbinutils xbinutils)))
+ `(("xlibc" ,(make-mingw-w64
+ machine
+ #:xgcc xgcc
+ #:xbinutils xbinutils)))
'())))
(build-system gnu-build-system)
(search-paths
@@ -85,9 +88,11 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
(add-before 'configure 'setenv
(lambda* (#:key inputs #:allow-other-keys)
(let ((xgcc-core (assoc-ref inputs "xgcc-core"))
- (mingw-headers (string-append (getcwd) "/mingw-w64-headers")))
+ (mingw-headers (string-append
+ (getcwd) "/mingw-w64-headers")))
(setenv "CPP"
- (string-append xgcc-core ,(string-append "/bin/" triplet "-cpp")))
+ (string-append
+ xgcc-core ,(string-append "/bin/" triplet "-cpp")))
(setenv "CROSS_C_INCLUDE_PATH"
(string-append
mingw-headers
@@ -96,11 +101,11 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
":" mingw-headers "/defaults/include"
":" mingw-headers "/direct-x/include"))
(when ,with-winpthreads?
- (let ((xlibc (assoc-ref inputs "xlibc")))
- (setenv "CROSS_LIBRARY_PATH"
- (string-append
- xlibc "/lib" ":"
- xlibc "/" ,triplet "/lib"))))))))
+ (let ((xlibc (assoc-ref inputs "xlibc")))
+ (setenv "CROSS_LIBRARY_PATH"
+ (string-append
+ xlibc "/lib" ":"
+ xlibc "/" ,triplet "/lib"))))))))
#:make-flags (list "DEFS=-DHAVE_CONFIG_H -D__MINGW_HAS_DXSDK=1")
#:tests? #f ; compiles and includes glibc headers
#:strip-binaries? #f))