summaryrefslogtreecommitdiff
path: root/gnu/packages/minetest.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-10 17:07:23 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-08-20 12:41:55 +0200
commit46a28e01b4bb47feab064d9ed327a99313e1d17e (patch)
tree7cf7f4941ac860fa3ecd079be7b31559d7bbb4b7 /gnu/packages/minetest.scm
parenta471acd9d3b7ab9dc5c2cd4fb8aceb1077d6c0b2 (diff)
downloadguix-patches-46a28e01b4bb47feab064d9ed327a99313e1d17e.tar
guix-patches-46a28e01b4bb47feab064d9ed327a99313e1d17e.tar.gz
gnu: Add minetest-unifieddyes.
* gnu/packages/minetest.scm (minetest-unifieddyes): New variable. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/minetest.scm')
-rw-r--r--gnu/packages/minetest.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index 97d4d3c9ac..8b9eb30a6a 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -85,3 +85,32 @@ with different rules and mechanics.")
;; <https://github.com/minetest-mods/mesecons/issues/575>.
(license (list license:lgpl3+ license:cc-by-sa3.0))
(properties `((upstream-name . "Jeija/mesecons"))))))
+
+(define-public minetest-unifieddyes
+ (package
+ (name "minetest-unifieddyes")
+ ;; Upstream uses dates as version numbers.
+ (version "2021-04-20-1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/VanessaE/unifieddyes")
+ (commit "ff3b2d30fa0df5c7181fdd401b989de6271c3bb3")))
+ (sha256
+ (base32
+ "0rba9n192xcpmxwnq7ixb6mn32gkpic247j3w4mwinrqcyscacsv"))
+ (file-name (git-file-name name version))))
+ (build-system minetest-mod-build-system)
+ (propagated-inputs
+ `(("minetest-basic-materials" ,minetest-basic-materials)))
+ (home-page (minetest-topic 2178))
+ (synopsis
+ "Unified Dyes expands the standard dye set of Minetest to up to 256 colours")
+ (description "The purpose of this mod originally was to supply a complete
+set of colours for Minetest mod authors to use for colourised nodes or
+reference in recipes. Since the advent of the default dyes mod in the standard
+Minetest game, this mod has become an extension of the default mod an a library
+for general colour handling.")
+ (license license:gpl2+)
+ (properties `((upstream-name . "VanessaE/unifieddyes")))))