summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-18 21:58:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-18 22:03:56 +0200
commitf3b64ad54ed7067094d752921f85341cdc0722fe (patch)
tree4531b32e7035a88841eeec2bd70035110f806b1f /gnu/packages/messaging.scm
parent860c2077ebcf39e8b76ad492f64a7c8e8b9de05e (diff)
downloadguix-patches-f3b64ad54ed7067094d752921f85341cdc0722fe.tar
guix-patches-f3b64ad54ed7067094d752921f85341cdc0722fe.tar.gz
gnu: gajim: Update to 1.3.3.
* gnu/packages/messaging.scm (gajim): Update to 1.3.3. [arguments]: Remove 'disable-failing-tests phase, as all now pass. Don't explicitly return #t from other phases.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 69d1ed87c1..d07c1c6566 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1069,7 +1069,7 @@ of xmpppy.")
(define-public gajim
(package
(name "gajim")
- (version "1.3.2")
+ (version "1.3.3")
(source
(origin
(method url-fetch)
@@ -1078,7 +1078,7 @@ of xmpppy.")
(version-major+minor version)
"/gajim-" version ".tar.gz"))
(sha256
- (base32 "1vjzv8zg9s393xw81klcgbkn4h6j2blzla9iil5kqfrw7wmldskh"))
+ (base32 "1337qkpcv7j0fgws9scnk82mn2l7s17060vmrbh3ihinmxmbxg6x"))
(patches (search-patches "gajim-honour-GAJIM_PLUGIN_PATH.patch"))))
(build-system python-build-system)
(arguments
@@ -1092,13 +1092,6 @@ of xmpppy.")
(guix build utils))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda _
- ;; ModuleNotFoundError: No module named 'gajim.gui.emoji_data'
- ;; https://dev.gajim.org/gajim/gajim/-/issues/10478
- (delete-file "test/lib/gajim_mocks.py")
- (delete-file "test/unit/test_gui_interface.py")
- #t))
(replace 'check
(lambda _
;; Tests require a running X server.
@@ -1106,8 +1099,7 @@ of xmpppy.")
(setenv "DISPLAY" ":1")
;; For missing '/etc/machine-id'.
(setenv "DBUS_FATAL_WARNINGS" "0")
- (invoke "dbus-launch" "python" "./setup.py" "test")
- #t))
+ (invoke "dbus-launch" "python" "./setup.py" "test")))
(add-after 'install 'glib-or-gtk-compile-schemas
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
(add-after 'install 'glib-or-gtk-wrap
@@ -1123,8 +1115,7 @@ of xmpppy.")
(wrap-program file
`("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))))
- '("gajim" "gajim-remote" "gajim-history-manager")))
- #t)))))
+ '("gajim" "gajim-remote" "gajim-history-manager"))))))))
(native-search-paths
(list
(search-path-specification