summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2020-12-31 00:14:25 -0500
committerDanny Milosavljevic <dannym@scratchpost.org>2021-01-03 17:30:29 +0100
commitf0e429a21809d5e5722cd1638ba3f666b3b1edb2 (patch)
tree8b3510bb60e7b3805752a5b4476ae4c2ccd866a3 /gnu/packages/messaging.scm
parent823567803f5afd9edf663b29b4e62ac0581cbfec (diff)
downloadguix-patches-f0e429a21809d5e5722cd1638ba3f666b3b1edb2.tar
guix-patches-f0e429a21809d5e5722cd1638ba3f666b3b1edb2.tar.gz
gnu: pidgin: Enable support for Tk.
* gnu/packages/messaging.scm (pidgin) [inputs]: Add tk. [arguments]<#:configure-flags>[--with-tkconfig]: New flag. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 7f6b2df834..bb449b5c0f 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -786,7 +786,8 @@ authentication.")
("silc" ,silc-toolkit)
("sqlite" ,sqlite)
("startup-notification" ,startup-notification)
- ("tcl" ,tcl)))
+ ("tcl" ,tcl)
+ ("tk" ,tk)))
(propagated-inputs
`(("glib" ,glib)))
(arguments
@@ -795,7 +796,6 @@ authentication.")
"--disable-gtkspell"
;; "--enable-gevolution"
"--enable-cap"
- "--disable-tcl"
"--enable-mono"
"--disable-vv" ; XXX remove when we have farstream and gstreamer
"--disable-gstreamer" ; XXX patches needed to support gstreamer-1.0
@@ -805,6 +805,9 @@ authentication.")
"/include")
(string-append "--with-tclconfig="
(assoc-ref %build-inputs "tcl")
+ "/lib")
+ (string-append "--with-tkconfig="
+ (assoc-ref %build-inputs "tk")
"/lib"))))
(native-search-paths
(list