summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2016-09-21 23:58:29 -0400
committerEfraim Flashner <efraim@flashner.co.il>2016-10-09 12:11:43 +0300
commitbc1c995e6ed7bde9a5c12fa66ea805485690afb1 (patch)
treee60888af63fd9fdf5edeaf9a7af66e6c574c4708 /gnu/packages/messaging.scm
parent62ea44fc890abd5c269d14684334ee09ace290fc (diff)
downloadguix-patches-bc1c995e6ed7bde9a5c12fa66ea805485690afb1.tar
guix-patches-bc1c995e6ed7bde9a5c12fa66ea805485690afb1.tar.gz
gnu: Add qtox.
* gnu/packages/messaging.scm (qtox): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 5a618c2742..8fffee9da0 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 ng0 <ngillmann@runbox.com>
+;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,6 +33,7 @@
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system python)
#:use-module (gnu packages)
+ #:use-module (gnu packages aidc)
#:use-module (gnu packages autotools)
#:use-module (gnu packages avahi)
#:use-module (gnu packages check)
@@ -661,6 +663,58 @@ protocols.")
instant messenger with audio and video chat capabilities.")
(home-page "http://utox.org/")
(license license:gpl3)))
+
+(define-public qtox
+ (package
+ (name "qtox")
+ (version "1.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/qTox/qTox/archive/v"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0y15mc39x54k1kz36cw9412kl1p1p6nzlx97gagv4gg3vybfhbjv"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (inputs
+ `(("ffmpeg" ,ffmpeg)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+-2)
+ ("libsodium" ,libsodium)
+ ("libtoxcore" ,libtoxcore)
+ ("libvpx" ,libvpx)
+ ("libxscrnsaver" ,libxscrnsaver)
+ ("libx11" ,libx11)
+ ("openal" ,openal)
+ ("qrencode" ,qrencode)
+ ("qt" ,qt)
+ ("sqlcipher" ,sqlcipher)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("qmake" ,qt)))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-reproducibility-issues
+ (lambda _
+ (substitute* "src/main.cpp"
+ (("__DATE__") "\"\"")
+ (("__TIME__") "\"\"")
+ (("TIMESTAMP") "\"\""))
+ #t))
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (zero?
+ (system* "qmake"
+ (string-append "PREFIX="
+ (assoc-ref outputs "out")))))))))
+ (home-page "https://qtox.github.io/")
+ (synopsis "Tox chat client using Qt")
+ (description "qTox is a Tox client that follows the Tox design
+guidelines. It provides an easy to use application that allows you to
+connect with friends and family without anyone else listening in.")
+ (license license:gpl3+)))
(define-public pybitmessage
(package