summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-11-17 23:43:29 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-21 21:54:10 +0100
commitb2d8174400369d69c27d6dd3914f77cc34388ea8 (patch)
tree0a346560bdbf6c4affbf2447d4364b9f3a9e498f /gnu/packages/messaging.scm
parent97a8d0edda15194c47f41ce0027ee404f0f55ef0 (diff)
downloadguix-patches-b2d8174400369d69c27d6dd3914f77cc34388ea8.tar
guix-patches-b2d8174400369d69c27d6dd3914f77cc34388ea8.tar.gz
gnu: Add qxmpp.
* gnu/packages/messaging.scm (qxmpp): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 9f4134362a..6a84f43bad 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2020, 2021 Robert Karszniewicz <avoidr@posteo.de>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -391,6 +392,47 @@ conferencing.")
license:gpl2+
license:bsd-2))))
+(define-public qxmpp
+ (package
+ (name "qxmpp")
+ (version "1.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/qxmpp-project/qxmpp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1knpq1jkwk0lxdwczbmzf7qrjvlxba9yr40nbq9s5nqkcx6q1c3i"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags (list "-DBUILD_EXAMPLES=false"
+ "-DWITH_GSTREAMER=true")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "ctest" "-E"
+ (string-join ;; These tests use the network.
+ (list "tst_qxmppiceconnection"
+ "tst_qxmppcallmanager"
+ "tst_qxmpptransfermanager")
+ "|"))))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gstreamer" ,gstreamer)
+ ("qtbase" ,qtbase-5)))
+ (home-page "https://github.com/qxmpp-project/qxmpp")
+ (synopsis "XMPP client and server library")
+ (description
+ "QXmpp is a XMPP client and server library written in C++ and uses the Qt
+framework. It builds XMPP clients complying with the XMPP Compliance Suites
+2021 for IM and Advanced Mobile.")
+ (license license:lgpl2.1+)))
+
(define-public meanwhile
(package
(name "meanwhile")