summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-11 20:50:30 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-11 20:51:51 +0100
commitaaf0e47f6dbe4245ef5d38f69e0e4eb2855de15b (patch)
treec8ae4702c4e2be3ba88ab369b585d29d8154bf3b /gnu/packages/messaging.scm
parente874f34d3f65ced7bee226b07210cdfc81dece30 (diff)
downloadguix-patches-aaf0e47f6dbe4245ef5d38f69e0e4eb2855de15b.tar
guix-patches-aaf0e47f6dbe4245ef5d38f69e0e4eb2855de15b.tar.gz
gnu: libtoxcore: Update to 0.0.0-2.bf69b54.
* gnu/packages/messaging.scm (libtoxcore): Update to 0.0.0-2.bf69b54. [native-inputs]: Add check.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 9d652486f2..a7b868ccc0 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -818,8 +818,8 @@ protocols.")
(license license:x11)))
(define-public libtoxcore
- (let ((revision "1")
- (commit "755f084e8720b349026c85afbad58954cb7ff1d4"))
+ (let ((revision "2")
+ (commit "bf69b54f64003d160d759068f4816b2d9b2e1e21"))
(package
(name "libtoxcore")
(version (string-append "0.0.0" "-"
@@ -832,20 +832,19 @@ protocols.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "0ap1gvlyihnfivv235dbrgsxsiiz70bhlmlr5gn1027w3h5kqz8w"))))
+ "11lqra4yd7v293cp286ynff5lqz1pprzg8vn3wq6vryj08g88zqb"))))
(build-system gnu-build-system)
+ (arguments `(#:tests? #f)) ; FIXME: tests hang, some fail.
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
- ;; TODO: Add when test suite is capable of passing.
- ;; ("check" ,check)
+ ("check" ,check)
("pkg-config" ,pkg-config)))
(inputs
`(("libsodium" ,libsodium)
("opus" ,opus)
("libvpx" ,libvpx)))
- (arguments `(#:tests? #f)) ; FIXME: Testsuite fails, reasons unspecific.
(synopsis "Library for the Tox encrypted messenger protocol")
(description
"C library implementation of the Tox encrypted messenger protocol.")