summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-04-09 18:23:50 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-04-09 18:29:10 +0200
commit8615e21a8cfb01882b4785c950ccb89edc9c4bcc (patch)
treee1192d8f79f492082548bdda09bf7144f69fedd9 /gnu/packages/messaging.scm
parentba1030be409d31e3509c8943c5f897376e73bb27 (diff)
downloadguix-patches-8615e21a8cfb01882b4785c950ccb89edc9c4bcc.tar
guix-patches-8615e21a8cfb01882b4785c950ccb89edc9c4bcc.tar.gz
gnu: pidgin: Update to 2.14.3.
* gnu/packages/messaging.scm (pidgin): Update to 2.14.3. [arguments]: Add an 'eat-leftovers phase.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index e8b67c03bc..64aada69f5 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -788,7 +788,7 @@ authentication.")
(define-public pidgin
(package
(name "pidgin")
- (version "2.14.2")
+ (version "2.14.3")
(source
(origin
(method url-fetch)
@@ -796,7 +796,7 @@ authentication.")
(string-append "mirror://sourceforge/pidgin/Pidgin/"
version "/pidgin-" version ".tar.gz"))
(sha256
- (base32 "19r297ynxizdj357ihmy0sgpgfikdzblkszlwlqnsr3lvbjhhsg1"))
+ (base32 "0vdfnm96m1kh4gm6xn6i7s9c5zjh1p18jg4595k4p5bplvd6fmm8"))
(patches
(search-patches "pidgin-add-search-path.patch"))
(modules '((guix build utils)))
@@ -875,7 +875,16 @@ authentication.")
"/lib")
(string-append "--with-tkconfig="
(assoc-ref %build-inputs "tk")
- "/lib"))))
+ "/lib"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'eat-leftovers
+ ;; XXX Remove when updating beyond 2.14.3. Equivalent to
+ ;; <https://keep.imfreedom.org/pidgin/pidgin/rev/d4d72fde60c2>.
+ (lambda _
+ ;; Remove a lingering [broken] oscar reference.
+ (substitute* "libpurple/tests/check_libpurple.c"
+ ((".*oscar_util_suite.*") "")))))))
(native-search-paths
(list
(search-path-specification