summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2020-05-10 15:49:22 +0200
committerMarius Bakke <marius@gnu.org>2020-05-26 22:36:11 +0200
commit76623b6703ce3d5780d742fd7b5285aa0cf7041d (patch)
tree1bc4eb02a3b8bde75b56001ad25da3e4b188cff6 /gnu/packages/messaging.scm
parent1f49f5c14ae0f16847e29f78ea5419cbe3bdb679 (diff)
downloadguix-patches-76623b6703ce3d5780d742fd7b5285aa0cf7041d.tar
guix-patches-76623b6703ce3d5780d742fd7b5285aa0cf7041d.tar.gz
gnu: nheko: Update to 0.7.1.
* gnu/packages/messaging.scm (nheko): Update to 0.7.1. [inputs]: Add qtdeclarative, qtgraphicaleffects and qtquickcontrols2. Arrange qtsvg in alphabetical order. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 754373d355..8042aa0eea 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1881,7 +1881,7 @@ for the Matrix protocol. It is built on to of @code{Boost.Asio}.")
(define-public nheko
(package
(name "nheko")
- (version "0.6.4")
+ (version "0.7.1")
(source
(origin
(method git-fetch)
@@ -1890,7 +1890,7 @@ for the Matrix protocol. It is built on to of @code{Boost.Asio}.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "19dkc98l1q4070v6mli4ybqn0ip0za607w39hjf0x8rqdxq45iwm"))))
+ (base32 "12sxibbrn79sxkf9jrm7jrlj7l5vz15claxrrll7pkv9mv44wady"))))
(arguments
`(#:tests? #f ;no test target
#:configure-flags
@@ -1920,8 +1920,11 @@ for the Matrix protocol. It is built on to of @code{Boost.Asio}.")
("mtxclient" ,mtxclient)
("openssl" ,openssl)
("qtbase" ,qtbase)
- ("qtsvg" ,qtsvg)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtgraphicaleffects" ,qtgraphicaleffects)
("qtmultimedia" ,qtmultimedia)
+ ("qtquickcontrols2" ,qtquickcontrols2)
+ ("qtsvg" ,qtsvg)
("spdlog" ,spdlog)
("tweeny" ,tweeny)
("zlib" ,zlib)))