summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-01-30 19:45:30 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-01-30 19:48:09 +0100
commit5a12bdaf8ce72ca715abe7268081632f54d0609d (patch)
tree432af64f901ad0944bc41bd66cc494bcc9086003 /gnu/packages/messaging.scm
parentd3c6ad0ab5de589c71b660928412bba8857c48c8 (diff)
downloadguix-patches-5a12bdaf8ce72ca715abe7268081632f54d0609d.tar
guix-patches-5a12bdaf8ce72ca715abe7268081632f54d0609d.tar.gz
gnu: bitlbee: Update to 3.5.1 [security fixes].
* gnu/packages/messaging.scm (bitlbee): Update to 3.5.1. [source]: Remove patches. (%bitlbee-buddy-nick-change-patch): Remove. (%bitlbee-always-use-nicks-patch): Remove.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm25
1 files changed, 2 insertions, 23 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index bd7e2bfa06..af44da5a1f 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -116,37 +116,16 @@ keys, no previous conversation is compromised.")
(home-page "https://otr.cypherpunks.ca/")
(license (list license:lgpl2.1 license:gpl2))))
-;; These patches together fix https://github.com/bitlbee/bitlbee/pull/55, are
-;; already upstream, and should be unnecessary when the next bitlbee comes
-;; out.
-(define %bitlbee-buddy-nick-change-patch
- (origin
- (method url-fetch)
- (uri "https://github.com/bitlbee/bitlbee/commit/a42fda42.patch")
- (sha256
- (base32
- "1mzjhcdn0rxir5mzgqz9kv142ai38p1iq2lajqx89wb7x0bp51zx"))))
-(define %bitlbee-always-use-nicks-patch
- (origin
- (method url-fetch)
- (uri "https://github.com/bitlbee/bitlbee/commit/3320d6d9.patch")
- (sha256
- (base32
- "14d9kb5zdzh5hzakdvrbviz83rix0j2lq9rzb58b2fn92fp8yixd"))))
-
(define-public bitlbee
(package
(name "bitlbee")
- (version "3.4.2")
+ (version "3.5.1")
(source (origin
(method url-fetch)
(uri (string-append "https://get.bitlbee.org/src/bitlbee-"
version ".tar.gz"))
(sha256
- (base32 "0mza8lnfwibmklz8hdzg4f7p83hblf4h6fbf7d732kzpvra5bj39"))
- (patches
- (list %bitlbee-buddy-nick-change-patch
- %bitlbee-always-use-nicks-patch))))
+ (base32 "0sgsn0fv41rga46mih3fyv65cvfa6rvki8x92dn7bczbi7yxfdln"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
("check" ,check)))