summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-10 04:46:29 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-10 04:48:29 +0100
commit4bf8348ff388246378e374db5fd2450c4cfb9fe5 (patch)
treede34b02f7236a5f2d55fd109c18934da946b5843 /gnu/packages/messaging.scm
parent1825e4548493051070316e2a12802797e8c72b84 (diff)
downloadguix-patches-4bf8348ff388246378e374db5fd2450c4cfb9fe5.tar
guix-patches-4bf8348ff388246378e374db5fd2450c4cfb9fe5.tar.gz
gnu: gajim: Restore 'disable-failing-tests phase.
Gajim consistently builds on my machines & bayfront, whilst raghavgururajan reports the exact same derivation consistently failing with the commented error. Odd. * gnu/packages/messaging.scm (gajim)[arguments]: Restore the old 'disable-failing-tests phase.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 4856df732e..3509327427 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1209,6 +1209,13 @@ of xmpppy.")
(guix build utils))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda _
+ ;; XXX Gajim builds fine on some (my) machines but fails elsewhere:
+ ;; ModuleNotFoundError: No module named 'gajim.gui.emoji_data'
+ ;; https://dev.gajim.org/gajim/gajim/-/issues/10478
+ (delete-file "test/lib/gajim_mocks.py")
+ (delete-file "test/unit/test_gui_interface.py")
(replace 'check
(lambda _
;; Tests require a running X server.