summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-03 20:18:47 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-03 21:49:54 +0200
commit413f8f3fa58d732ad20a1c65d64e3ab36a71b51b (patch)
treef04e00250d9fa01bf3d29e1202167baf7e4f58c8 /gnu/packages/messaging.scm
parentf7f7b9f423fe0056c2d1f90c8063d6a92dee25c9 (diff)
downloadguix-patches-413f8f3fa58d732ad20a1c65d64e3ab36a71b51b.tar
guix-patches-413f8f3fa58d732ad20a1c65d64e3ab36a71b51b.tar.gz
gnu: hexchat: Update to 2.16.0.
* gnu/packages/messaging.scm (hexchat): Update to 2.16.0. [source]: Remove patch. [inputs]: Remove libnotify and libproxy. Upgrade python-2 to python@3. Add python-cffi and bash-minimal. [arguments]: Don't explicitly return #t from phases. Add a new 'wrap-program phase.
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm36
1 files changed, 22 insertions, 14 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index a7fed957a3..6b4f26880c 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -85,6 +85,7 @@
#:use-module (gnu packages kerberos)
#:use-module (gnu packages less)
#:use-module (gnu packages libcanberra)
+ #:use-module (gnu packages libffi)
#:use-module (gnu packages libidn)
#:use-module (gnu packages libreoffice)
#:use-module (gnu packages linux)
@@ -709,15 +710,14 @@ used by Pidgin and Bitlbee, among others, to access
(define-public hexchat
(package
(name "hexchat")
- (version "2.14.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://dl.hexchat.net/hexchat/hexchat-"
- version ".tar.xz"))
- (patches (search-patches "hexchat-add-libera-chat.patch"))
- (sha256
- (base32
- "10p829jm1r6kidkgf5lhqhyqc5mxdcq96q3zhadsckasvc9rs6lh"))))
+ (version "2.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://dl.hexchat.net/hexchat/hexchat-"
+ version ".tar.xz"))
+ (sha256
+ (base32 "0dnwhb2gi08i5v79vq0y2izs89wyk3by96jv99kgkidjic3k2bj1"))))
(build-system meson-build-system)
(native-inputs `(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin") ;need glib-genmarshal
@@ -728,14 +728,16 @@ used by Pidgin and Bitlbee, among others, to access
("enchant" ,enchant)
("gtk" ,gtk+-2)
("libcanberra" ,libcanberra)
- ("libnotify" ,libnotify)
- ("libproxy" ,libproxy)
("openssl" ,openssl)
;; Bindings for add-on scripts.
("luajit" ,luajit)
("perl-xml-parser" ,perl-xml-parser)
- ("python-2" ,python-2)))
+ ("python" ,python)
+ ("python-cffi" ,python-cffi)
+
+ ;; For the ensuing WRAP-PROGRAM.
+ ("bash-minimal" ,bash-minimal)))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -747,8 +749,14 @@ used by Pidgin and Bitlbee, among others, to access
;; just skip this code.
(substitute* "meson_post_install.py"
(("if 'DESTDIR' not in os.environ:")
- "if False:"))
- #t)))))
+ "if False:"))))
+ (add-after 'install 'wrap-program
+ ;; Let it ‘initialize the Python-CFFI embedding logic’ at run time.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (wrap-program (string-append bin "/hexchat")
+ `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))))))))
(synopsis "Graphical IRC client")
(description
"HexChat lets you connect to multiple IRC networks at once. The main