summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-08 09:06:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-08 09:06:14 +0200
commit1c94392a13cbdf87e03a644633eb775bf45694a1 (patch)
tree74f11038dfc5f9d9db06660b1087253b28c5434f /gnu/packages/messaging.scm
parentdd87bbb2b78b279248aaff15c0706fcd6d8cd7bb (diff)
parent9d25ee30b188f9202cc14f7cd25ba8a1c3ec1a72 (diff)
downloadguix-patches-1c94392a13cbdf87e03a644633eb775bf45694a1.tar
guix-patches-1c94392a13cbdf87e03a644633eb775bf45694a1.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm119
1 files changed, 118 insertions, 1 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 9a3cfc9308..479ed00c94 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
;;; Copyright © 2016, 2017, 2018, 2019 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
-;;; Copyright © 2017, 2018, 2020 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017, 2018, 2020, 2021 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
@@ -2986,4 +2986,121 @@ API. Mattermost is not required.")
(home-page "https://github.com/42wim/matterbridge")
(license license:asl2.0)))
+(define-public weechat-matrix
+ (package
+ (name "weechat-matrix")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/poljar/weechat-matrix")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1iv55n4k05139f7jzkhczgw4qp6qwilrvfsy3c6v2m1kxffj12d3"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((weechat-python (string-append (assoc-ref outputs "out")
+ "/share/weechat/python")))
+ ;; Avoid circular import by renaming the matrix module to
+ ;; weechat_matrix.
+ (substitute* (cons "main.py"
+ (append (find-files "matrix")
+ (find-files "tests")))
+ (("from matrix") "from weechat_matrix")
+ (("import matrix") "import weechat_matrix"))
+ ;; Install python modules.
+ (invoke "make" "install-lib"
+ (string-append "INSTALLDIR="
+ (site-packages inputs outputs)
+ "/weechat_matrix"))
+ ;; Extend PYTHONPATH to find installed python modules.
+ (add-installed-pythonpath inputs outputs)
+ ;; Augment sys.path so that dependencies are found.
+ (substitute* "main.py"
+ (("import os\n" all)
+ (apply string-append
+ all
+ "import sys\n"
+ (map (lambda (path)
+ (string-append "sys.path.append('" path "')\n"))
+ (string-split (getenv "PYTHONPATH") #\:)))))
+ ;; Install script.
+ (mkdir-p weechat-python)
+ (copy-file "main.py"
+ (string-append weechat-python "/matrix.py")))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (inputs
+ `(("python-matrix-nio" ,python-matrix-nio)
+ ("python-pygments" ,python-pygments)
+ ("python-pyopenssl" ,python-pyopenssl)
+ ("python-webcolors" ,python-webcolors)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/poljar/weechat-matrix")
+ (synopsis "Weechat Matrix protocol script")
+ (description "@code{weechat-matrix} is a Python plugin for Weechat that lets
+Weechat communicate over the Matrix protocol.")
+ (license license:isc)))
+
+(define-public weechat-wee-slack
+ (package
+ (name "weechat-wee-slack")
+ (version "2.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wee-slack/wee-slack")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xfklr0gsc9jgxfyrrb2j756lclz9g8imcb0pk0xgyj8mhsw23zk"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Augment sys.path so that dependencies are found.
+ (substitute* "wee_slack.py"
+ (("import sys\n" all)
+ (apply string-append
+ all
+ (map (lambda (path)
+ (string-append "sys.path.append('" path "')\n"))
+ (string-split (getenv "PYTHONPATH") #\:)))))
+ ;; Install script.
+ (install-file "wee_slack.py"
+ (string-append (assoc-ref outputs "out")
+ "/share/weechat/python"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
+ (inputs
+ `(("python-websocket-client" ,python-websocket-client)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/wee-slack/wee-slack")
+ (synopsis "Weechat Slack script")
+ (description "@code{weechat-wee-slack} is a WeeChat native client for
+Slack. It provides supplemental features only available in the web/mobile
+clients such as synchronizing read markers, typing notification, threads (and
+more)! It connects via the Slack API, and maintains a persistent websocket
+for notification of events.")
+ (license license:expat)))
+
;;; messaging.scm ends here