summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-18 16:05:21 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-18 19:50:01 +0200
commit0e47fcced442d8e7c1b05184fdc1c14f10ed04ec (patch)
tree4ae844bc0ec3c670f8697bdc24362c122fa718ad /gnu/packages/messaging.scm
parente4b70bc55a538569465bcedee19d1f2607308e65 (diff)
parent8b1bde7bb3936a64244824500ffe60f123704437 (diff)
downloadguix-patches-0e47fcced442d8e7c1b05184fdc1c14f10ed04ec.tar
guix-patches-0e47fcced442d8e7c1b05184fdc1c14f10ed04ec.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm19
1 files changed, 8 insertions, 11 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 9fd0e70afe..173119a8b1 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -580,7 +580,7 @@ identi.ca and status.net).")
(define-public bitlbee-discord
(package
(name "bitlbee-discord")
- (version "0.4.2")
+ (version "0.4.3")
(source
(origin
(method git-fetch)
@@ -589,23 +589,20 @@ identi.ca and status.net).")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "02pigk2vbz0jdz11f96sygdvp1j762yjn62h124fkcsc070g7a2f"))))
+ (base32 "00qgdvrp7hv02n0ns685igp810zxmv3adsama8601122al6x041n"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:configure-flags
+ (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "--with-bdatadir=" out "/share/bitlbee/")
+ (string-append "--with-plugindir=" out "/lib/bitlbee/")))
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-autogen
(lambda _
(let ((sh (which "sh")))
(substitute* "autogen.sh" (("/bin/sh") sh))
- (setenv "CONFIG_SHELL" sh))
- #t))
- (replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (invoke "./configure"
- (string-append "--with-plugindir="
- (assoc-ref outputs "out")
- "/lib/bitlbee/")))))))
+ (setenv "CONFIG_SHELL" sh)))))))
(inputs `(("glib" ,glib)))
(native-inputs `(("pkg-config" ,pkg-config)
("autoconf" ,autoconf)