summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-03 14:25:30 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-03 14:27:51 +0200
commit075df3d3e2f86ad2548075969b34402a3c40ec42 (patch)
tree303b422a84ce5ee1fccff610eaf83b20919e8b87 /gnu/packages/messaging.scm
parentaba40a6b7fdce56fe439668b3152ae4d4ddd1551 (diff)
parentb2721c3656e0ddf76dcccccfbacaaa309d2f47fe (diff)
downloadguix-patches-075df3d3e2f86ad2548075969b34402a3c40ec42.tar
guix-patches-075df3d3e2f86ad2548075969b34402a3c40ec42.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm26
1 files changed, 10 insertions, 16 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 8f67e6628c..9a3cfc9308 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -239,7 +239,7 @@ Its design goals are simplicity and stability.")
(define-public libgnt
(package
(name "libgnt")
- (version "2.14.1")
+ (version "2.14.3")
(source
(origin
(method url-fetch)
@@ -247,7 +247,7 @@ Its design goals are simplicity and stability.")
(string-append "mirror://sourceforge/pidgin/libgnt/"
version "/libgnt-" version ".tar.xz"))
(sha256
- (base32 "1n2bxg0ignn53c08cp69pj4sdg53kwlqn23rincyjmpr327fdhsy"))))
+ (base32 "08v14fjcx2wx6c573wllq015l6zc8qkpz8rrl6qhp7crf9zlbxap"))))
(build-system meson-build-system)
(outputs '("out" "doc"))
(arguments
@@ -260,16 +260,14 @@ Its design goals are simplicity and stability.")
(("'/usr'")
(string-append "'"
(assoc-ref inputs "ncurses")
- "'")))
- #t))
+ "'")))))
(add-before 'configure 'patch-docbook-xml
(lambda* (#:key inputs #:allow-other-keys)
(with-directory-excursion "doc"
(substitute* "libgnt-docs.xml"
(("http://www.oasis-open.org/docbook/xml/4.1.2/")
(string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook/"))))
- #t))
+ "/xml/dtd/docbook/"))))))
(add-after 'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -277,8 +275,7 @@ Its design goals are simplicity and stability.")
(mkdir-p (string-append doc "/share"))
(rename-file
(string-append out "/share/gtk-doc")
- (string-append doc "/share/gtk-doc"))
- #t))))))
+ (string-append doc "/share/gtk-doc"))))))))
(native-inputs
`(("docbook-xml" ,docbook-xml-4.1.2)
("glib:bin" ,glib "bin")
@@ -1330,14 +1327,14 @@ default.")
(define-public prosody
(package
(name "prosody")
- (version "0.11.9")
+ (version "0.11.10")
(source (origin
(method url-fetch)
(uri (string-append "https://prosody.im/downloads/source/"
"prosody-" version ".tar.gz"))
(sha256
(base32
- "02gzvsaq0l5lx608sfh7hfz14s6yfsr4sr4kzcsqd1cxljp35h6c"))))
+ "1q84s9cq7cgzd295qxa2iy0r3vd3v3chbck62bdx3pd6skk19my6"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ;tests require "busted"
@@ -1353,16 +1350,14 @@ default.")
;; The configure script aborts when it encounters unexpected
;; arguments. Make it more tolerant.
(substitute* "configure"
- (("exit 1") ""))
- #t))
+ (("exit 1") ""))))
(add-after 'unpack 'fix-makefile
(lambda _
(substitute* "GNUmakefile"
;; prosodyctl needs to read the configuration file.
(("^INSTALLEDCONFIG =.*") "INSTALLEDCONFIG = /etc/prosody\n")
;; prosodyctl needs a place to put auto-generated certificates.
- (("^INSTALLEDDATA =.*") "INSTALLEDDATA = /var/lib/prosody\n"))
- #t))
+ (("^INSTALLEDDATA =.*") "INSTALLEDDATA = /var/lib/prosody\n"))))
(add-after 'install 'wrap-programs
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Make sure all executables in "bin" find the required Lua
@@ -1398,8 +1393,7 @@ default.")
`("LUA_PATH" ";" = (,lua-path))
`("LUA_CPATH" ";" = (,lua-cpath))
`("PATH" ":" prefix ,path)))
- (find-files bin ".*"))
- #t))))))
+ (find-files bin ".*"))))))))
(inputs
`(("libidn" ,libidn)
("openssl" ,openssl)