summaryrefslogtreecommitdiff
path: root/gnu/packages/mes.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2018-10-12 10:44:24 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2018-10-21 23:26:21 +0200
commitf266199dc1e547dee2d7e946e9dd9a9bb17fca89 (patch)
treef4cbe7a376f0742a0f854fd33ae306ee6c7cfc43 /gnu/packages/mes.scm
parente065823a593c337f17af3f4ba7341d458be7bdf3 (diff)
downloadguix-patches-f266199dc1e547dee2d7e946e9dd9a9bb17fca89.tar
guix-patches-f266199dc1e547dee2d7e946e9dd9a9bb17fca89.tar.gz
gnu: mes: Update to 0.18.0-08f04f55.
This update is a preparation for the %bootstrap-mes package; due to some small problems it fails to build with plain mes-0.18. mes-boot0 stays at 0.18 only to avoid another rebuild world. %bootstrap-mes brings the building and packaging the Mes bootstrap seeds from manual operation into Guix. We will bump mes and mes-boot0 to a future 0.18.1 or 0.19 and regenerate %bootstrap-mes in a nex iteration. 08f04f55 build: Oops, remove stray lib/linux/x86_64-mes/crt1. 33f37f27 build: x86_64 bootstrap build fixes and workaround. 4ae2a111 doc: Release update. 5277669b mescc: Oops, delete wrong line of assembly. 44cc97a8 admin: Release update. * gnu/packages/mes.scm (mes): Update to 0.18.0-08f04f55. * gnu/packages/commencement.scm (mes-boot0): Stay at 0.18.0.
Diffstat (limited to 'gnu/packages/mes.scm')
-rw-r--r--gnu/packages/mes.scm24
1 files changed, 15 insertions, 9 deletions
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index 6dc6dfb4cb..4f98cd24f0 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -60,17 +60,22 @@ extensive examples, including parsers for the Javascript and C99 languages.")
(license (list gpl3+ lgpl3+))))
(define-public mes
- (let ((triplet "i686-unknown-linux-gnu"))
+ (let ((triplet "i686-unknown-linux-gnu")
+ (version "0.18")
+ (revision "0")
+ (commit "08f04f559670d9e8f57eb03bb9b13f4d0b81cedf"))
(package
(name "mes")
- (version "0.18")
+ (version (string-append version "-" revision "." (string-take commit 7)))
(source (origin
(method url-fetch)
- (uri (string-append "mirror://gnu/mes/"
- "mes-" version ".tar.gz"))
+ (uri (string-append
+ "https://git.savannah.gnu.org/cgit/mes.git/snapshot/"
+ name "-" commit
+ ".tar.gz"))
(sha256
(base32
- "1dsaaqyanzsq9m5wrcd2bjhb3qd6928c9q97rg5r730pyqjwxyxf"))))
+ "1b7wz9k38pfrz707pd4p8s54q903jr167q73ya7qkna89sxj3wna"))))
(build-system gnu-build-system)
(supported-systems '("i686-linux" "x86_64-linux"))
(propagated-inputs
@@ -93,10 +98,11 @@ extensive examples, including parsers for the Javascript and C99 languages.")
`(#:strip-binaries? #f)) ; binutil's strip b0rkes MesCC/M1/hex2 binaries
(synopsis "Scheme interpreter and C compiler for full source bootstrapping")
(description
- "GNU Mes [Maxwell Equations of Software] aims to create full source
-bootstrapping for GuixSD. It consists of a mutual self-hosting [close to
-Guile-] Scheme interpreter prototype in C and a Nyacc-based C compiler in
-[Guile] Scheme.")
+ "GNU Mes--Maxwell Equations of Software--brings the Reduced
+Binary Seed bootstrap to GuixSD and aims to help create full source
+bootstrapping for GNU/Linux distributions. It consists of a mutual
+self-hosting Scheme interpreter in C and a Nyacc-based C compiler in
+Scheme and is compatible with Guile.")
(home-page "https://gnu.org/software/mes")
(license gpl3+))))