summaryrefslogtreecommitdiff
path: root/gnu/packages/mes.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-06-13 09:36:42 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-13 13:00:36 +0200
commitb8016467273d06ffe3780ac97d38acfd72ce15d9 (patch)
treed5096c8ac00add5a0c1fb1b059edf1c0f7e405eb /gnu/packages/mes.scm
parent4d6d2d7cca222b8a6f5c63340a058f4c4cc7ed28 (diff)
downloadguix-patches-b8016467273d06ffe3780ac97d38acfd72ce15d9.tar
guix-patches-b8016467273d06ffe3780ac97d38acfd72ce15d9.tar.gz
gnu: nyacc: Add 0.94.0.
* gnu/packages/mes.scm (nyacc): Rename to... (nyacc-0.86): ... this. (nyacc): New variable. (mes)[propagated-inputs]: Use NYACC-0.86 instead of NYACC.
Diffstat (limited to 'gnu/packages/mes.scm')
-rw-r--r--gnu/packages/mes.scm39
1 files changed, 37 insertions, 2 deletions
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index afb1e025b4..ae887fa24d 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -29,6 +29,7 @@
#:use-module (gnu packages man)
#:use-module (gnu packages package-management)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages texinfo)
#:use-module (guix build-system gnu)
#:use-module (guix download)
@@ -36,7 +37,7 @@
#:use-module (guix licenses)
#:use-module (guix packages))
-(define-public nyacc
+(define-public nyacc-0.86
(package
(name "nyacc")
(version "0.86.0")
@@ -59,6 +60,37 @@ extensive examples, including parsers for the Javascript and C99 languages.")
(home-page "https://savannah.nongnu.org/projects/nyacc")
(license (list gpl3+ lgpl3+))))
+(define-public nyacc
+ (package
+ (inherit nyacc-0.86)
+ (version "0.94.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/nyacc/nyacc-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "12qnzwm1n3j8z7hbr9hy2wka9a1aasm2rvnpnvdxkjcsbdzj8fn4"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* (find-files "." "^Makefile\\.in$")
+ (("^SITE_SCM_DIR =.*")
+ "SITE_SCM_DIR = \
+@prefix@/share/guile/site/@GUILE_EFFECTIVE_VERSION@\n")
+ (("^SITE_SCM_GO_DIR =.*")
+ "SITE_SCM_GO_DIR = \
+@prefix@/lib/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n")
+ (("^INFODIR =.*")
+ "INFODIR = @prefix@/share/info\n")
+ (("^DOCDIR =.*")
+ "DOCDIR = @prefix@/share/doc/$(PACKAGE_TARNAME)\n"))
+ #t))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-2.2)))))
+
(define-public mes
(package
(name "mes")
@@ -74,7 +106,10 @@ extensive examples, including parsers for the Javascript and C99 languages.")
(supported-systems '("i686-linux" "x86_64-linux"))
(propagated-inputs
`(("mescc-tools" ,mescc-tools)
- ("nyacc" ,nyacc)))
+
+ ;; XXX: MesCC appears to enter an infinite loop (?) while building
+ ;; crt1.o when we switch to nyacc 0.94.
+ ("nyacc" ,nyacc-0.86)))
(native-inputs
`(("guile" ,guile-2.2)
,@(let ((target-system (or (%current-target-system)